Upcoming and past changes to application compatibility · 2012-03-16 08:02 by Wladimir Palant
Starting with version 2.0 Adblock Plus requires at least Firefox 3.6.13 to be installed (or Thunderbird 3.1.7 or SeaMonkey 2.1). We really don’t support earlier Firefox 3.6 versions because of a critical bug that will cause Flash to break. Unfortunately, this limitation initially couldn’t be enforced by technical means (due to a limitation on addons.mozilla.org) so some people with old Firefox 3.6 versions nevertheless got it installed. If you are one of them: you should update your browser as soon as possible, already because of the numerous known security issues in the old versions.
Please note that support for Firefox 3.6 is running out, only one more security update (Firefox 3.6.29) is scheduled. If you are still using Firefox 3.6 you should update to a current Firefox version — currently Firefox 11. Next Adblock Plus release (most likely named Adblock Plus 2.1) will no longer support Firefox 3.6. Technically, it will require at least Firefox 8/Thunderbird 8/SeaMonkey 2.5. However, given that outdated versions have very few users which means that issues will go unnoticed — it is only realistic to support the current release and the one before. So the officially supported versions now would start with Firefox 10, and once Firefox 12 is released we would only support Firefox 11 and higher — using earlier browser versions would be at your own risk.
Commenting is closed for this article.