Adblock Plus and (a little) more

Upcoming and past changes to application compatibility · 2012-03-16 08:02 by Wladimir Palant

Starting with version 2.0 Adblock Plus requires at least Firefox 3.6.13 to be installed (or Thunderbird 3.1.7 or SeaMonkey 2.1). We really don’t support earlier Firefox 3.6 versions because of a critical bug that will cause Flash to break. Unfortunately, this limitation initially couldn’t be enforced by technical means (due to a limitation on so some people with old Firefox 3.6 versions nevertheless got it installed. If you are one of them: you should update your browser as soon as possible, already because of the numerous known security issues in the old versions.

Please note that support for Firefox 3.6 is running out, only one more security update (Firefox 3.6.29) is scheduled. If you are still using Firefox 3.6 you should update to a current Firefox version — currently Firefox 11. Next Adblock Plus release (most likely named Adblock Plus 2.1) will no longer support Firefox 3.6. Technically, it will require at least Firefox 8/Thunderbird 8/SeaMonkey 2.5. However, given that outdated versions have very few users which means that issues will go unnoticed — it is only realistic to support the current release and the one before. So the officially supported versions now would start with Firefox 10, and once Firefox 12 is released we would only support Firefox 11 and higher — using earlier browser versions would be at your own risk.


Comment [3]

  1. Zef · 2012-03-16 09:49 · #

    One thing about supporting just the previous version…

    What about the new ERS versions?

    (Firefox 10.0.3 = 11.0 security fixes, or something like that.)

    Reply from Wladimir Palant:

    Yes, I thought about this. But I don’t have Mozilla’s resources – I cannot support a version that only a handful of people are using. If people stay with an outdated Firefox version for a year they probably won’t mind staying with an outdated Adblock Plus version as well.

  2. EP · 2012-03-22 04:15 · #


    just to let you know that Firefox 12 and Seamonkey 2.9 (which will be released in late April 2012) will be the last versions of those apps to support Windows 2000 (and pre-SP2 versions of Windows XP like WinXP RTM/SP1). Firefox 13, Seamonkey 2.10.0 & higher will only run under Windows XP SP2 or greater. Mozilla had decided to create their apps using MSVC 2010, which requires minimum WinXP SP2 – starting with FF 13.

    and Mozilla will retire support for Firefox 3.6 (aka. going to EOL) when Firefox 12 is officially released in late April. last version of FF 3.6 is version 3.6.28.

  3. theo zilinsku · 2012-04-22 00:04 · #

    are ‘numerous’ security concerns all that horrible for the user running with neither admin-context (that which makes opencandy malware) nor out-of-box settings for os or kernel?

    SpooFX (pen testing) requires a legacy version of firefox. And who wants to see the interweb sans adblocking? — BLOCKING ALL the ads by default. :P

    opt-out is not sufficient. I don’t want a default opt-in as that is antithetical to opt. AdBlock Lite fork addresses these concerns.

    given how few users there are why wait? and why bother giving notice? just make sweeping changes based on statistically insignificant population. how could that possibly go wrong?

    Reply from Wladimir Palant:

    Yes, the security concerns are a big deal. Using a non-admin account is non-sense, malware doesn’t need administrator privileges to either install in the system or to do damage. Using a non-Windows OS also isn’t a reliable protection (and will become even less so in future). Please consider that if your computer is sending spam or hacking websites then it isn’t merely your problem, you are causing a problem for everybody.

    There are other extensions doing referrer spoofing that are still being maintained, you should find one that works. Without knowing what exactly you need, a brief search finds RefControl and hxxp.

    But if you want to stick with an outdated Firefox version because of an outdated and unmaintained extension then you probably won’t mind using an outdated Adblock Plus version. Or a broken fork if you prefer. I for my part have been supporting Firefox 3.6 way longer than reasonable but support for it has to be dropped if I want to improve Adblock Plus.

    Do you expect an answer to the bogus accusations in the last paragraph of your comment?

Commenting is closed for this article.