Why doesn't my custom rules work?

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Why doesn't my custom rules work?

Postby q1741171 » Thu Oct 12, 2017 11:43 am

Hello. I tried searching, and found this post: viewtopic.php?t=22023
I tried it, but for some reason it does not work for me.
The rules are not whitelisted; some elements are hidden as intended, but for instance this example:
https://imgur.com/a/2mUW6
Three domains should be blocked, but none are.
Please, is my synthax wrong? Did I forgot to add some characters?
Thank you.
q1741171
 
Posts: 4
Joined: Thu Oct 12, 2017 11:26 am

Re: Why doesn't my custom rules work?

Postby mapx » Thu Oct 12, 2017 11:54 am

firefox version ?

"allow some non intrusive advertising" is enabled or disabled ?

Site / page where your filters are not working (anymore) ?

However, you should try the last beta ABP ==> is a completely new ABP for firefox (the same ABP for chrome) which since FF 57 will be used because the old one ("legacy") will be avoided by mozilla
https://addons.mozilla.org/en-US/firefo ... sions/beta
or
https://addons.mozilla.org/downloads/la ... vbuild.xpi
User avatar
mapx
 
Posts: 20950
Joined: Thu Jan 06, 2011 3:01 pm

Re: Why doesn't my custom rules work?

Postby q1741171 » Fri Oct 13, 2017 12:38 pm

Oh, sorry - firefox 56.0 64-bit, should have added more info.

Allowing NIA is disabled, all ads should be blocked.

Example site is non-english, but:
Code: Select all
http://zpravy.idnes.cz/biopaliva-letecka-paliva-plany-produkce-dopravci-fbv-/zahranicni.aspx?c=A171013_101455_zahranicni_ert


I tried the developer build, and it is still not blocking those elements I have blacklisted.
Nothing is whitelisted.

Upon closer inspection, it seems that the block is partial - I tried to disable all filter lists, and now the only custom rule for the aforementioned site is
Code: Select all
||bbelements.com^
.
Image ads are indeed blocked, but there are non-image (text-embeded, a clickable hyperlink under certain words in the text) present.
Thank you.
q1741171
 
Posts: 4
Joined: Thu Oct 12, 2017 11:26 am

Re: Why doesn't my custom rules work?

Postby mapx » Fri Oct 13, 2017 12:44 pm

well, the bbelements scripts are blocked using that filter, right ?

Now - if you want to block / hide something else you should provide exact indications what / where on page are those elements.
User avatar
mapx
 
Posts: 20950
Joined: Thu Jan 06, 2011 3:01 pm

Re: Why doesn't my custom rules work?

Postby q1741171 » Sun Nov 05, 2017 7:39 pm

It is not being blocked.

https://imgur.com/a/RuxfK
on page
https://ekonomika.idnes.cz/profese-prace-firmy-poptavka-djc-/ekonomika.aspx?c=A171102_102823_ekonomika_vem

As you can see, ABP is told to block some of the scripts, but is not blocking them.
q1741171
 
Posts: 4
Joined: Thu Oct 12, 2017 11:26 am

Re: Why doesn't my custom rules work?

Postby mapx » Sun Nov 05, 2017 11:00 pm

Easyprivacy is blocking gemius and ibillboard, just look in "blockable items list"

However, you should use the last beta build of ABP (the only available when FF 57 will land)

Or, you could use uBo and the polish lists (containing specific uBo filters)
User avatar
mapx
 
Posts: 20950
Joined: Thu Jan 06, 2011 3:01 pm


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: No registered users and 23 guests