Strange thing with Adblock and Firefox

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Strange thing with Adblock and Firefox

Postby alien826 » Thu Mar 14, 2019 11:01 pm

Something strange started happening a few weeks back.

When I clicked on a link in an Email, first time after Firefox was opened it opened the page correctly in Firefox. Thereafter I got a pop up that Firefox was not responding. Firefox itself continued to work normally and would accept the link when I copied and pasted it into the browser. This was happening on both my Windows 7 PC and my Windows 10 PC, and was not restricted to a particular Email client. Another symptom was that when I clicked on a link with Firefox not running, causing it to start up, it would flash up (something?) which immediately went away then bring up the Firefox window, but Firefox would be "behind" the mail client window, where normally a new window would be on top. I had the latest version of Adblock (3.5) and auto update on.

After a lot of research and messing around, I tried starting Firefox in Safe mode, where the problem did not occur. That seemed to suggest an add-on as causing the problem, and I found that disabling (NOT removing) Adblock also made it go away. What's interesting is that after I enabled Adblock again the problem (including the "double start") has not recurred. Also Firefox seems to be a lot faster in its responses.

Any ideas?

Edited to add ...

I rebooted and it came back. Here's a better description.

1. Problem exists.
2. Disable Adblock. Problem exists.
3. Restart Firefox. Problem goes away.
4. Enable Adblock. Still no problem.
5. Restart Firefox. Problem returns.
alien826
 
Posts: 2
Joined: Thu Mar 14, 2019 10:44 pm

Re: Strange thing with Adblock and Firefox

Postby alien826 » Sat Mar 16, 2019 9:04 pm

Well, nobody else has experienced this? Or doesn't have an answer? Anyway, I've found one.

I experimented with other ad blockers and found that I got the same symptoms with Adblocker*, but not with Ghostery. So, rather than spend more time chasing this problem, it's Ghostery for me from now on.

I've used Adblock plus for years with no problems, but enough is enough, sorry. If I hear that this problem has been identified and fixed I may come back. Or not.

* I'm not 100% sure about Adblocker, as it may be necessary to totally remove Adblock plus and I'm not sure I did that. Maybe there's something in the start menu that runs even when the add-on is disabled? Whatever.
alien826
 
Posts: 2
Joined: Thu Mar 14, 2019 10:44 pm

Re: Strange thing with Adblock and Firefox

Postby sbell » Tue Mar 19, 2019 12:29 am

Hey there!

Apologies for the late reply! I've ran a few tests on my end but wasn't able to reproduce the issue. I will however, make our testers and developers aware of this so we can investigate a bit further. Can you give us some example links to sites where the issue occurred? We're happy to help!

Thanks
Shannon
ABP Support Team
sbell
ABP Technical Support Specialist
 
Posts: 98
Joined: Wed Jul 05, 2017 8:08 pm


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: No registered users and 7 guests