Blocking even with no filters

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Blocking even with no filters

Postby Alan » Tue Oct 11, 2005 3:18 am

Discovered an interesting problem over in the Filterset.G forum which is not filter set related, but does appear to be an Adblock problem nevertheless.

Windows XP Home
Mozilla Firefox 1.07
Adblock Plus

!Filterset.G-Whitelist-Beta[http://www.pierceive.com/]=wb-2005-09-05a
!Filterset.G[http://www.pierceive.com/]=2005-09-18a

http://trickstutorials.com/index.php?pa ... t/t_aerial
http://trickstutorials.com/index.php?pa ... t_aubatido
No account

There are large blank spaces where instructions and accompanying pictures should be. This occurs in every trick tutorial they have on the site.

This problem occurs even if there are no filters! I did discover that the images and text were displayed properly if I disabled "Check Parent Links", but I have no idea what's going on because there aren't any filters. The images and accompanying text are blocked even though the Adblock-able Items window show them as not being blocked.

mcm_ham, you're our only hope. What's going on?
--
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Adblock_Plus_0.5.9.2_enh.xpi
Alan
 

Postby mcm » Tue Oct 11, 2005 4:46 am

Must be a Firefox 1.0.x problem, it's working fine for me on Firefox 1.5 beta.
User avatar
mcm
 
Posts: 359
Joined: Sat Jun 10, 2006 2:36 am

Postby Alan » Tue Oct 11, 2005 6:45 am

mcm wrote:Must be a Firefox 1.0.x problem, it's working fine for me on Firefox 1.5 beta.

You sure got out of that one easy. "Fixed in the next release" works for me too. :wink:
Alan
 

Postby mcm » Tue Oct 11, 2005 12:44 pm

That's just a quick remark from me trying to reproduce, at the moment I've only got some spare time in the weekends so will see what the story is then and whether a fix is possible. I've had other similar cases on Fx 1.0.x which weren't resolvable and just disabled Adblock in those particular situations, meaning you can see them but aren't blockable.
User avatar
mcm
 
Posts: 359
Joined: Sat Jun 10, 2006 2:36 am

Postby Alan » Tue Oct 11, 2005 9:26 pm

Thank you for the clarification. I've heard that Fx 1.5 might be released as early as the end of this month, so if it's not a problem in Fx 1.5 then it might not be a priority fix. On the other hand, only if and when you have time, it might be productive to figure out what the problem is in Fx 1.0.x. It could be a lurking bug that causes a regression in Fx 1.5.x. Thanks again for your work on Adblock Plus. I can't get over that you're supporting Adblock too!
Alan
 

Postby mcm » Sat Oct 15, 2005 4:01 am

Ok, the issue is fixed in the developer builds now:
http://p2.forumforfree.com/development- ... kplus.html
User avatar
mcm
 
Posts: 359
Joined: Sat Jun 10, 2006 2:36 am

Postby mcm » Sun Oct 16, 2005 2:11 am

Apologies, had to undo that fix because of it caused other problems:
http://p2.forumforfree.com/bug-with-reg ... kplus.html

I think I'll just have to leave it be, but no there is no underlying problem in the code just a bug in Firefox 1.0 that's been fixed in Firefox 1.5.
User avatar
mcm
 
Posts: 359
Joined: Sat Jun 10, 2006 2:36 am

Postby Alan » Sun Oct 16, 2005 2:33 am

mcm wrote:I think I'll just have to leave it be, but no there is no underlying problem in the code just a bug in Firefox 1.0 that's been fixed in Firefox 1.5.

Thank you for checking it out. I can sleep now. :wink:
Alan
 


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: No registered users and 14 guests