[OS.File API] Compatibility

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

[OS.File API] Compatibility

Postby guest » Sat Apr 05, 2014 4:15 am

The latest ABP dev build (2.5.1.3789) works fine in Firefox 18. Why is it marked as compatible with only Gecko 19+?
Related changeset: https://hg.adblockplus.org/adblockplus/rev/3af12903c104
guest
 

Re: Compatibility

Postby guest » Fri Apr 11, 2014 8:21 pm

bump
(2.5.1.3791 still seems to work with Fx 18. Also, there are no ABP-related messages in Error Console.)
guest
 

Re: Compatibility

Postby mapx » Fri Apr 11, 2014 8:34 pm

https://issues.adblockplus.org/ticket/153

"We should drop the hacks in favor of ​OS.File API which provides async versions of all necessary file operations. Most of it became available with Firefox 18 meaning that we have to drop support for Firefox 17 "

most of it ==> probably os.file api became stable since firefox 19
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Compatibility

Postby guest » Sat Apr 12, 2014 12:02 am

Thanks for your reply. This is a standard release (downloaded from mozilla.org) Firefox 18.0.2 with no special configuration to enable "unstable" APIs, so since OS.File is enabled and working here, it should be "stable".

Also, I decided to run code that displays all enumerable and exposed properties of OS.File and OS.File.prototype in this browser, and all the properties of each that ABP depends on are there and they don't obviously look like they would only throw errors...

What am I missing?
(Is it working only because I'm on Linux, and some other platforms didn't get OS.File until Gecko 19?)
guest
 

Re: [OS.File API] Compatibility

Postby mapx » Sat Apr 12, 2014 12:42 am

put your comments in the issue (see the link above) and probably a developer will answer your doubts
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: [OS.File API] Compatibility

Postby guest » Sat Apr 12, 2014 6:23 pm

mapx wrote:put your comments in the issue (see the link above) and probably a developer will answer your doubts

I'm pretty sure that the developers are correct in marking Gecko 18 incompatible (my system here is a testing environment). I was just curious why; the issue tracker somehow doesn't seem an appropriate place to ask that kind of question, and posting on a closed issue doesn't feel like it will be noticed.
Are you saying the devs don't read the forums??

Do the developers read and respond to emails sent to the addresses mentioned on the hg repositories?
guest
 

Re: [OS.File API] Compatibility

Postby mapx » Sat Apr 12, 2014 6:28 pm

User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm


Re: [OS.File API] Compatibility

Postby Wladimir Palant » Sun Apr 13, 2014 1:05 pm

Quoting my reply for the issue tracker:

The documentation on OS.File isn't very clear as far as compatibility goes - most of it landed in Gecko 18, some changes were added in Gecko 19 however. I decided to go with Gecko 19 because I didn't want to risk subtle behavior differences breaking something. Why is that important? Anybody should be using Firefox 28 or at the very least Firefox 24 ESR right now, there is absolutely no good reason to use Firefox 18.
Wladimir Palant
ABP Developer
 
Posts: 8398
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: agrohimjni and 6 guests