Page 1 of 1

Blocking items that conflict with disabled whitelisted rules

PostPosted: Mon Jun 01, 2009 2:22 pm
by Parson
When I try to block an image from
https://www.some-nasty-example-site.com/image.gif
in the list of blockable items I right-click on it and choose "Block this item...".

I would expect the window that usually lets me refine my rule to come up but nothing happens. The reason might be that I have a rule that whitelists https-pages (this rule is displayed beneath the item).
But:
a) this https-whitelisting rule is disabled
b) in those cases usually ABP greyes the "Block this item..." menuitem out, but not in this case.

Is this a bug or intended? A misconfiguration on my side?

PostPosted: Mon Jun 01, 2009 2:29 pm
by Wladimir Palant
One possible reason I can think of is the Skype extension - if you have it installed, please disable. It horribly messes up the browser.

Otherwise: maybe you can install the current Adblock Plus development build and type "chrome://adblockplus/content/errors.html" into the location bar after seeing this issue (without quotation marks). Please paste any errors listed into this forum thread.

PostPosted: Mon Jun 01, 2009 2:44 pm
by Parson
Thanks for the quick answer!

I don't have the Skype extension istalled.
I installed the latest dev build for ABP as you suggested but nothing changed.

This is what I tried:
1. Create a filter @@https://* but disable it
2. Open the page http://userstyles.org/
3. Open the list of blockable items
4. There should be an item https://m.kallout.com/abc/source.php?id=stylish&img=2 The filter displayed beneath is the one created in 1. It is greyed out because the filter is disabled
5. Right click on it this item and chose "Block this item...". Nothing happens.

PostPosted: Mon Jun 01, 2009 2:51 pm
by Wladimir Palant

PostPosted: Mon Jun 01, 2009 2:57 pm
by Parson
Image