Adblock problem on computer lab computer

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Adblock problem on computer lab computer

Postby Student » Fri Nov 06, 2009 1:49 am

On a certain computer (this one) at my educational institution, installing Adblock (using the "Get Add-ons" function) works, however when restarting the browser to complete installation, Adblock does not work. No filter subscription window is opened, the entry in the extension list has no icon, and clicking "Options" freezes the Add-ons window (NOT the main browser windows though).

Firefox 3.5.1 (We can install extensions, but not update Firefox)
Latest Adblock
Microsoft Windows XP SP3

Other extensions:
Java Quick State
Microsoft .NET Framework Assistant (Disabled by Firefox)

Default theme and no others

Plugins:
Acrobat
Itunes application detector
Java Platform SE 6 U12 (this is listed twice)
Microsoft DRM (listed twice)
Mozilla Default Plug-in
National Instruments LabVIEW 8.2 Netscape Plug-in for Windows (twice)
Office Genuine Advantage
Oracle JInitiator
QuickTime Plug-in
RealJukebox NS Plugin
RealNetworks Rhapsody Player Engine
RealNetworks Version Plugin
RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)
SciFinder Application Plugin for Mozilla
Shockwave Flash
Shockwave for Director
Silverlight Plug-In
Windows Media Player Plug-in Dynamic Link Library
Windows Presentation Foundation (disabled)

Thank you,

Student
Student
 

Re: Adblock problem on computer lab computer

Postby Hubird » Fri Nov 06, 2009 3:06 am

Sounds like a permissions problem to me, might no be much you can do about it.

I used to use a portable version of Firefox with ABP installed on a USB stick, you might have to resort to something similar.
User avatar
Hubird
 
Posts: 2850
Joined: Thu Oct 26, 2006 2:59 pm
Location: Australia

Re: Adblock problem on computer lab computer

Postby Wladimir Palant » Fri Nov 06, 2009 9:21 am

Wladimir Palant
ABP Developer
 
Posts: 8398
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Re: Adblock problem on computer lab computer

Postby Student » Sat Nov 07, 2009 6:20 am

I don't think it is a permissions affair since I am able to install the extension (Using Firefox), only it doesn't appear to function when installed.

Also, I checked that link and none of the options seemed to apply (IE. There weren't any of those errors shown).
Student
 

Re: Adblock problem on computer lab computer

Postby Wladimir Palant » Sat Nov 07, 2009 11:16 pm

Sorry, I misunderstood the problem. Firefox thinks that Adblock Plus is installed but its files aren't accessible. This could be either because the files really aren't there (extensions/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}/chrome/adblockplus.jar missing in Firefox profile) or because these files weren't registered correctly. You can probably check whether adblockplus.jar file is there. If it is a registration problem however - I have no idea, I guess uninstalling and reinstalling the extension doesn't help either?
Wladimir Palant
ABP Developer
 
Posts: 8398
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Re: Adblock problem on computer lab computer

Postby Student » Tue Nov 10, 2009 10:44 pm

C:\Program Files\Mozilla Firefox\extensions doesn't show a directory with that name.

Unfortunately the installation on this machine is rather strange, with some network-delivered applications and some locally installed one (Firefox is both). Is there any way to find out where the "profile directory" is from within Firefox?

K
Student
 

Re: Adblock problem on computer lab computer

Postby Student » Tue Nov 10, 2009 10:46 pm

Sorry for the double post, but I just noticed this:

On a re-installation (Un install, restart, install, restart), "No chrome package registered for chrome://adblockplus/skin/adblockplus.png" appears in Error Console.
Student
 

Re: Adblock problem on computer lab computer

Postby Wladimir Palant » Wed Nov 11, 2009 5:33 pm

Student, it is in the profile folder, not the application directory: http://support.mozilla.com/en-US/kb/Pro ... ur_profile
Wladimir Palant
ABP Developer
 
Posts: 8398
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Re: Adblock problem on computer lab computer

Postby Student » Wed Nov 18, 2009 1:19 am

C:\Documents and Settings\[username]\Application Data\Mozilla\Firefox\Profiles\jx7hp1ib.default\extensions\{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}\chrome\adblockplus.jar does exist. Is there any thing else that I can check to help debug this?
Student
 

Re: Adblock problem on computer lab computer

Postby Wladimir Palant » Wed Nov 18, 2009 9:08 am

As I said - I have no idea then :-(
Wladimir Palant
ABP Developer
 
Posts: 8398
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: No registered users and 14 guests