Page 1 of 1

Adblock does not remember filters, does not let me restore

PostPosted: Sun May 28, 2017 10:11 am
by udo
Firefox latest on Fedora 24 x86_64: firefox-53.0.2-5.fc24.x86_64
Adblock plus 2.9.

Suddenly I see an advert on youtube.
I try to report an issue.
Then Adblock mentions there are no filter rules.
So I add a few, make a backup (~/filters).
I shut down FF after a while.
I start it up again.
I check the filters: gone.
I try to restore the backup.
Due to a non added extension to ~/filters the file is not recognised.
Renaming it to filters.txt does allow recognition as a custom filter but the file is not accepted.

So I guess I need help to find the root causes of these issues.
Why does FF forhget the filters?
Why can't I restore the filters?
Is this related to FF changing?

Re: Adblock does not remember filters, does not let me restore

PostPosted: Sun May 28, 2017 2:29 pm
by udo
Found that the extension expected is .ini.
So why does adblock not show this?
Why does adblock pro not add this on making a backup?
Shut down FF.
Started it again.
Filter rules gone!
What type of product is this? Was it ever tested?
This was never an issue before.
So why now?

Re: Adblock does not remember filters, does not let me restore

PostPosted: Mon May 29, 2017 4:49 am
by udo
Due to this bug I have to restore the filters each time I start up FF.
We choose to restore, select the file and click OK.
Then comes another question asking if it is OK to proceed.
Why then did I select a file to restore from?

Re: Adblock does not remember filters, does not let me restore

PostPosted: Mon May 29, 2017 1:13 pm
by mapx

Re: Adblock does not remember filters, does not let me restore

PostPosted: Mon May 29, 2017 3:30 pm
by udo
When restoring an ini file and closing the dialog after selecting a file, the filters do not get imported.
One has to WAIT for the useless dialog to indicate we really want to restore stuff.
Then it takes a few seconds and only then we can proceed.

Re: Adblock does not remember filters, does not let me restore

PostPosted: Mon May 29, 2017 3:38 pm
by udo

Re: Adblock does not remember filters, does not let me restore

PostPosted: Sun Jun 25, 2017 1:51 pm
by kma1623
I use FF52.2.0 (32bit). For me, this problem started when I updated from 2.8.2 to 2.9.

Solved the problem by reinstalling 2.8.2.

Forgot about it until I updated to 2.9.1.

Same problem.

Solved the problem by reinstalling 2.8.2. Again.

Indeed, didn't even have to re-select the filters. They were there already as soon as I went back to the earlier version.

Could it be that 2.9 and after looks for the filters in the wrong place in the profile?

Re: Adblock does not remember filters, does not let me restore

PostPosted: Sun Jul 02, 2017 12:13 pm
by jayjonbeach
Another thread of people with same issue: viewtopic.php?f=1&t=53075&start=0

I just keep restoring for now until there is hopefully a solution, other than going to older version

Re: Adblock does not remember filters, does not let me restore

PostPosted: Sat Jul 08, 2017 5:49 pm
by mapx
Did you try disabling all other addons ?