Not working anymore?

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Not working anymore?

Postby jayjonbeach » Mon Jun 19, 2017 5:29 pm

Hi there. ABP has been a great great boon for internet use thank you! All of a sudden today, where I have done NO changes, FF did not update etc, it is not working anywhere, Yahoo, You tube etc?

Are others experiencing this?

It shows active on all pages, it is just not blocking anything?

TIA
jayjonbeach
 
Posts: 11
Joined: Mon Jun 19, 2017 5:24 pm

Re: Not working anymore?

Postby jayjonbeach » Mon Jun 19, 2017 6:27 pm

Not sure how, but it seems my ABP got corrupted or something. The last update was June 8, it stopped working today June 19.

I decided to restore a back-up from 2 days ago, and now it is blocking things again. It appears ALL my filter stuff was missing, the back up restored it.

Any ideas WHY this happened? I'm scared to let it update now, don't know if ABP is at fault, or something else never had this happen before.

Thoughts appreciated
jayjonbeach
 
Posts: 11
Joined: Mon Jun 19, 2017 5:24 pm

Re: Not working anymore?

Postby jayjonbeach » Mon Jun 19, 2017 7:13 pm

It just happened again, lost ALL the filters, had to backup again. I downloaded a CD from a site that uses BCVC shortner, and maybe one of the pop ups is corrupting ABP somehow it seems

Wonder why this is happening so easily
jayjonbeach
 
Posts: 11
Joined: Mon Jun 19, 2017 5:24 pm

Re: Not working anymore?

Postby Tinton3w » Mon Jun 19, 2017 11:09 pm

I think I'm experiencing the same problem? Every time I reload Firefox (close and open it) it loses its filter subscriptions and I have to re-add EasyList. I'm not having the same problem in Chrome or Opera.
Tinton3w
 
Posts: 1
Joined: Mon Jun 19, 2017 11:07 pm

Re: Not working anymore?

Postby UliBär » Mon Jun 19, 2017 11:38 pm

Same problem here with latest Adblock Plus update on Firefox 54.
Everytime i restart Firefox, all lists are gone. :(

BTW: Going back to Adblock Plus version 2.8.2 fixes the problem!
So there is definitely something fishy in the latest release. :idea:

[edit]
This happens on main PC with Win 7 pro 64 bit and also on notebook with Win 10 pro 64 bit.
On both systems i could fix this by going back to Adblock Plus version 2.8.2!
UliBär
 
Posts: 2
Joined: Mon Jun 19, 2017 11:34 pm

Re: Not working anymore?

Postby jayjonbeach » Wed Jun 21, 2017 8:26 pm

Yep, thing is totally flaky. I just restarted FF, and lost ALL the exceptions again. Have to back up every time. Can we get an ABP employee aware of this, and fixing it please?
jayjonbeach
 
Posts: 11
Joined: Mon Jun 19, 2017 5:24 pm

Re: Not working anymore?

Postby BlockAllTheThings » Thu Jun 22, 2017 2:02 am

On a couple of Win7 systems running Firefox 52.2.0 ESR, ABP 2.9.1, NoScript 5.0.5, and some other extensions (Multiprocess Windows disabled by addons, no syncing):

ABP appears to function properly (blocking confirmed, subscriptions visible in Filter Preferences, etc). Then, after some time and/or an unknown trigger:

  • It stops blocking things it should (serious)
  • Subscriptions are no longer visible in Filter Preferences
  • Custom filters are no longer visible in Filter Preferences
  • The filter rule panel on the right of Filter Preferences, which is normally expanded, is collapsed
Some ABP specific things:

  • Unchecked Allow some non-intrusive advertising
  • extensions.adblockplus.subscriptions_autoupdate=false
  • extensions.adblockplus.notificationurl=https://localhost/blockedrequest (no server listening)
  • extensions.adblockplus.subscriptions_fallbackurl=https://localhost/blockedrequest (no server listening)
  • extensions.adblockplus.patternsbackups=2
  • extensions.adblockplus.savestats=false
Restoring a previous backup solves the problem for a while, but then it eventually happens again (hours later, I think, with a browser restart in between pretty likely). I haven't been able to trigger the problem by restarting the browser or manually updating subscriptions.
BlockAllTheThings
 
Posts: 3
Joined: Thu Jun 22, 2017 1:09 am

Re: Not working anymore?

Postby jayjonbeach » Thu Jun 29, 2017 4:52 pm

Mine has mostly been behaving, no idea why seems pretty random, I did not do anything different. When it messes up, I just backup to older copy of ABP, it did it about 4 times in the last 2 weeks
jayjonbeach
 
Posts: 11
Joined: Mon Jun 19, 2017 5:24 pm

Re: Not working anymore?

Postby Marco » Thu Jun 29, 2017 9:33 pm

No.
I am not having any problems.
As long as it fully restores, which it always does (Firefox/FEBE/redundant backups), you should be fine.
You should make sure to always update after the restore, though.
I don't recall that my updates are ever older than three days, depending on the filter.
Marco
 
Posts: 108
Joined: Sat Dec 12, 2015 9:55 am

Re: Not working anymore?

Postby Alduin's Khajiit » Sat Jul 01, 2017 9:19 pm

Mine is not blocking anything either. Nothing at all is blocked.


It is funny that nobody from the admin team on this forums have said anything at all in this thread.
Alduin's Khajiit
 
Posts: 68
Joined: Thu Mar 06, 2014 4:19 am

Re: Not working anymore?

Postby mapx » Sun Jul 02, 2017 9:54 am

User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Not working anymore?

Postby jayjonbeach » Sun Jul 02, 2017 12:07 pm

Thanks for the link, good to know a ticket has been opened, would be nice if they fixed it..... TLDR - Are they actually working on it? (seems there are only 2 people in discussion, and no option for me to add to it)

Mine is on the fritz again today, IIRC FF updated yesterday so I'm thinking this is why it is acting up today after a restart
jayjonbeach
 
Posts: 11
Joined: Mon Jun 19, 2017 5:24 pm

Re: Not working anymore?

Postby jayjonbeach » Thu Jul 06, 2017 8:07 pm

Any word if Adblock is going to actually fix this? Acted up again today, this is a month old issue now, seems they are slacking
jayjonbeach
 
Posts: 11
Joined: Mon Jun 19, 2017 5:24 pm

Re: Not working anymore?

Postby mapx » Thu Jul 06, 2017 10:00 pm

just follow that issue.

what's your name there (did you register an account on the bug tracker ? ) so I can add you.
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Not working anymore?

Postby Jess » Sat Jul 15, 2017 3:42 pm

Adblock has been excellent for years without any issue and now it is suddenly not working for me at all. I am using Firefox and have Adblock version 2.9.1 I am not tech savvy but that was never an issue before as Adblock just worked and I'd 'disable on this page only' whenever a site refused access while using it. For no obvious reason at all it has completely stopped working and the APB sign still shows on each page but is doing nothing :(

I would really like a SIMPLE fix...I'm just not able to deal with trying this then that then the other because it stresses me out and I rarely manage to fix a computer issue when following 'solutions' online as I rarely even understand the terminology or what they're even talking about lol. I liked Adblock because it was a simple download and then boom, it works :) Please fix this!
Jess
 
Posts: 1
Joined: Sat Jul 15, 2017 3:28 pm

Next

Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: No registered users and 46 guests