Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby adelphi » Thu Feb 01, 2018 11:24 am

FireFox 58.0.1 and Adblock Plus 3.0.2:

Users can no longer control their OutlookWebApp (Exchange 2010 SP3 RU19) out-of-office settings when using FireFox 58.0.1 with Adblock plus 3.0.2. The webpage is not loading completely, even if I whitelist the page. It's only working if I completely disable the plugin.
adelphi
 
Posts: 5
Joined: Thu Feb 01, 2018 11:14 am

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby mapx » Thu Feb 01, 2018 11:42 am

How can be reproduced the issue ? it's free ? provide the steps.

see also https://adblockplus.org/forum/viewtopic.php?p=173281#p173281 to get the blocked elements and the triggered filters. Post them here.
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby adelphi » Thu Feb 01, 2018 6:30 pm

mapx wrote:How can be reproduced the issue ? it's free ? provide the steps.


Exchange Outlook Web App is never free. It's a Microsoft enterprise email solution, IMHO the most popular groupware worldwide. Sorry, I can't provide access to it.

When ABP is enabled and the URL not whitelistet, I get following error:
Message: NS_ERROR_ILLEGAL_VALUE:
Url: https://domain/ecp/14.3.382.0/Scripts/e ... ndalone.js
ErrorHandling.showUnhandledException@https://domain/ecp/14.3.382.0/Scripts/common.js:253:1205
Function.createDelegate/<@https://somain/ecp/14.3.382.0/Scripts/microsoftajax.js:5:305

It seems to be a problem by blocking JS?

If I whitelist the URL, the error disappears but the website doesn't load completely. Why does ABP has affect on whitelisted websites?

mapx wrote:see also viewtopic.php?p=173281#p173281 to get the blocked elements and the triggered filters. Post them here


Here is a list of all items shown by ABP:
||domain/ecp/14.3.382.0/Themes/Default/csssprites2.png
||domain/ecp/14.3.382.0/Themes/Default/culture_default.css
||domain/ecp/14.3.382.0/Themes/Default/main.css
||domain/ecp/14.3.382.0/Themes/Default/mainnavigationsprite.css
||domain/ecp/14.3.382.0/Themes/Default/navigation.css
||domain/ecp/14.3.382.0/Scripts/microsoftajax.js
||domain/ecp/14.3.382.0/Scripts/common.js
||domain/ecp/14.3.382.0/scripts/js.axd?resources=Common&v=14.3.382.0&c=de-DE
||domain/ecp/14.3.382.0/Themes/Default/clear1x1.gif
||domain/ecp/14.3.382.0/Themes/Default/headerbgright.png
||domain/ecp/14.3.382.0/Themes/Default/headerbgmain.png
||domain/ecp/14.3.382.0/Themes/Default/hdrdiv-l.png
||domain/ecp/14.3.382.0/Themes/Default/hdrdiv-t.png
||domain/ecp/14.3.382.0/Themes/Default/hdrdiv-r.png
||domain/ecp/14.3.382.0/Themes/Default/navigationsprite.png
||domain/ecp/14.3.382.0/Themes/Default/commandsprite.png
||domain/ecp/14.3.382.0/Themes/Default/mainnavigationsprite.png
||domain/ecp/14.3.382.0/Themes/Default/dividerrepeater.png
||domain/ecp/14.3.382.0/Themes/Default/horizontalsprite.png
||domain/ecp/Organize/AutomaticReplies.slab?showhelp=false&
||domain/ecp/14.3.382.0/Themes/Default/homepagesprite.css
||domain/ecp/14.3.382.0/Themes/Default/csssprites.css
||domain/ecp/14.3.382.0/Themes/Default/csssprites2.css
||domain/ecp/14.3.382.0/Themes/Default/editorstyles.css
||domain/ecp/14.3.382.0/Scripts/wizardproperties.js
||domain/ecp/14.3.382.0/Scripts/automaticreplies.js
||domain/ecp/14.3.382.0/Scripts/editorstandalone.js
||domain/ecp/14.3.382.0/Themes/Default/progress.gif
||domain/ecp/14.3.382.0/Themes/Default/arrowdhover.gif
||domain/ecp/14.3.382.0/Scripts/blank.htm
||domain/ecp/14.3.382.0/Themes/Default/csssprites.png
adelphi
 
Posts: 5
Joined: Thu Feb 01, 2018 11:14 am

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby mapx » Thu Feb 01, 2018 7:08 pm

You have to find (see on the red rows) the filter which blocks that script ! Post it here.
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby adelphi » Thu Feb 01, 2018 8:50 pm

mapx wrote:You have to find (see on the red rows) the filter which blocks that script ! Post it here.


There are no red lines! I think it's not a filter issue: I've even completely removed all ABP filter lists but the problem still occurs.
adelphi
 
Posts: 5
Joined: Thu Feb 01, 2018 11:14 am

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby mapx » Fri Feb 02, 2018 12:10 am

Could you test in chrome + ABP too ? If does work, could be a firefox bug

However you should report the issue directly on the bug tracker, could be the ABP devs can test it
https://issues.adblockplus.org
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby adelphi » Fri Feb 02, 2018 12:21 am

mapx wrote:Could you test in chrome + ABP too ? If does work, could be a firefox bug


No Problem with Chrome.

mapx wrote:However you should report the issue directly on the bug tracker, could be the ABP devs can test it
https://issues.adblockplus.org


OK, thanks.
adelphi
 
Posts: 5
Joined: Thu Feb 01, 2018 11:14 am

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby mapx » Fri Feb 02, 2018 12:33 am

another test: try FF 59 (beta) - you could use a portable one. If works could be the bug was fixed for the future releases.
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Bug: Exchange 2010 OutlookWebApp Out-of-Office control

Postby adelphi » Fri Feb 02, 2018 7:59 pm

mapx wrote:another test: try FF 59 (beta) - you could use a portable one. If works could be the bug was fixed for the future releases.


You are right! No problem with 59 beta.
adelphi
 
Posts: 5
Joined: Thu Feb 01, 2018 11:14 am


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: Maximusbcg, Maximusnss, Maximuspdd, Maximuspfr, Maximusqjd and 33 guests