Infinite loop, disc thrash

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Infinite loop, disc thrash

Postby bugbear » Sun Nov 15, 2020 12:08 pm

Until recently, ABP has worked perfectly for me.

But after my recent upgrade from Ubuntu 18 to 20, I've been getting an intermittent (yay!) fault.

On Facebook and Ancestry, I sometimes get an infinite loop, where my (SSD) drive light just turns on, and stays on, the CPU hits 100%, and the CPU load is "web content"

It's very difficult to diagnose, because when this happens, my machine essentially locks solid, with no response to mouse or keyboard. I have tried "waiting it out", but switched off after 10 minutes of no change.

I tried running Firefox at "nice -20", so that I might be able to diagnose something when it locked, but that didn't work either.

I have now disabled ABP for Facebook and Ancestry, and the lock ups have ceased (I think - they were intermittent anyway).

However, whilst Ancestry isn't ad heavy anyway, Facebook is pretty damn annoying in its unblocked form.

Is this a known issue? I've tried looking in the issue log, but got overwhelmed.

BugBear

Version(s) info:

bugbear@bugbear-dell:~$ uname -a
Linux bugbear-dell 5.4.0-53-generic #59-Ubuntu SMP Wed Oct 21 09:38:44 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

bugbear@bugbear-dell:~$ cat /etc/issue
Ubuntu 20.04.1 LTS \n \l

Firefox:82.0.3 (64-bit)

Adblock: Version number 3.9.5
bugbear
 
Posts: 1
Joined: Sun Nov 15, 2020 11:57 am

Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: ShanaBrum and 21 guests