A Few Questions - OUCH!

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

A Few Questions - OUCH!

Postby Marco » Sat Jan 30, 2021 4:56 am

Firefox 85.0
ABP 3.10.2
Easy List
Easy Privacy
Fanboys Social Media

First, I cannot open my settings from the dashboard - it is stuck. I cannot change some settings when I open it another way - so it is stuck there, also.
Second, I assume (may be a bad idea, but...) that I should uninstall and reinstall it.
I have a list of special filters, and I might be up to date, but I figured I would copy them now.
Cannot copy the list, for some reason.

This is bad.
(It started with a FF error about webpage slowing down browser, then after changing about:config, I began getting script errors.
I reversed the settings but the script errors remain.)

Thank you.
Marco
 
Posts: 120
Joined: Sat Dec 12, 2015 9:55 am

Re: A Few Questions - OUCH!

Postby greiner » Thu Feb 04, 2021 7:42 pm

Marco wrote:First, I cannot open my settings from the dashboard - it is stuck. I cannot change some settings when I open it another way - so it is stuck there, also.

Which dashboard are you referring to? I could try reproducing it myself, if you can provide some step-by-step instructions.

Marco wrote:Second, I assume (may be a bad idea, but...) that I should uninstall and reinstall it.
I have a list of special filters, and I might be up to date, but I figured I would copy them now.
Cannot copy the list, for some reason.

Assuming that you're still able to open the settings page, you can copy all your filters like this:

1. Open the "Advanced" tab in the settings page.
2. Select all your custom filters by clicking on the checkbox in the top-left corner of the custom filters table.
3. Click on "Copy selected" that appears at the bottom of the table.
4. Paste your filters into a text file.

You can then import them again later by pasting them into the input field at the top of the table.

Marco wrote:This is bad.
(It started with a FF error about webpage slowing down browser, then after changing about:config, I began getting script errors.
I reversed the settings but the script errors remain.)

It's not clear to me what exactly could be causing this because it sounds like you're experiencing a quite broad range of problems. So backing up your settings and reinstalling the browser may be the best way for you to get to a clean Firefox installation. Otherwise you may end up going from one problem to another.
User avatar
greiner
ABP Developer
 
Posts: 815
Joined: Mon Sep 03, 2012 5:29 pm
Location: Cologne, Germany

Re: A Few Questions - OUCH!

Postby Marco » Thu Feb 11, 2021 5:55 am

The dashboard when you click on the icon to open it. Not called a dashboard? What is it?

I fixed that.
Reinstalled ABP.
BUT yesterday, again, it was not opening. This morning, yes.

Re copying the custom filter list.
I remember getting those instructions.
My page doesn't look like you described, though. I see no check box on the top left corner of the filter table. Unapproachable triangle on right side, though.

https://imgur.com/a/iqWOsxe

You are right. It seems like a persistent and broad range of problems.
I just updated FF to 85.0.2 yesterday.
Still getting multitude of annoyances - mostly script errors and *A webpage is slowing down your browser.*

One of the repeated script errors in Outlook.com is this:
“A script from the extension “Adblock Plus - free ad blocker” is running on this page, and making Firefox unresponsive.
It may be busy, or it may have stopped responding permanently. You can stop the script now, or you can continue to see if it will complete.
Script: moz-extension://828d9f18-fde6-…ba8d22a8365/include.preload.js:1496629220“

Thank you.
Marco
 
Posts: 120
Joined: Sat Dec 12, 2015 9:55 am


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: MarvinPax and 21 guests