Adblock plus on latest trunk builds (20050919)

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

Adblock plus on latest trunk builds (20050919)

Postby Ger Teunis » Tue Sep 20, 2005 7:46 am

According to mozillazine forums, adblock is causing an error on displaying images.

.."Yes the problem with the alt tag showing up and the images not being displayed if you use AdBlock is a problem with the extension and not the browser...."
Ger Teunis
 

Postby mcm » Tue Sep 20, 2005 9:15 am

Yeah, it's because I haven't implemented XPCNativeWrappers and have just turned them off. For some reason that's causing a problem. But it's going to take me a while to make all the changes needed as there is quite a few.
User avatar
mcm
 
Posts: 359
Joined: Sat Jun 10, 2006 2:36 am

Postby Ger Teunis » Tue Sep 20, 2005 12:27 pm

Thanks for your reply! Hope you'll find the sollution.
Shout if I can be of any help.
Ger Teunis
 

Postby FLAMEX » Wed Sep 21, 2005 9:18 am

So, is there any update about this so call bug ..? I just can't wait to use AdBlock back..! :D By far, the greatest extension ever..!!
FLAMEX
 

Postby Guest » Wed Sep 21, 2005 6:38 pm

mcm wrote:If anyone knows how to get this line of code working with PCNativeWrappers I'd be appreciative.
window._extensionData = new Array();


I recommend to ask at irc in #developers.
Guest
 

Postby mcm » Thu Sep 22, 2005 3:51 am

There is no #developers channel that I can see on IRC, but have posted in the mozillazine forums and haven't got much of a response. Anyway there's a hacked version linked in the second post here that I'm hoping will work (untested). A proper fix may take me a while.

http://p2.forumforfree.com/development- ... kplus.html
User avatar
mcm
 
Posts: 359
Joined: Sat Jun 10, 2006 2:36 am

Postby Guest » Thu Sep 22, 2005 10:07 am

mcm wrote:There is no #developers channel that I can see on IRC, but have posted in the mozillazine forums and haven't got much of a response. Anyway there's a hacked version linked in the second post here that I'm hoping will work (untested). A proper fix may take me a while.

http://p2.forumforfree.com/development- ... kplus.html


Just join the channel via command line even if it is not listed.
Unforntunately the hacked version does not work for me.
Guest
 

Postby Guest » Thu Sep 22, 2005 8:14 pm

No good on the hacked version here either i'm afraid..
If you get the latest nightly trunk and then try http://www.apple.com you should be able to see straight away whether it works.
Guest
 

Postby Paulfox » Sat Sep 24, 2005 2:03 am

Just uninstalled 1.5b and reloaded 1.5b Sept 23 Nightly - AdBlock plus working FANTASTIC, no image problems;

I have DIV elements and ObjTabs unchecked.
Paulfox
 

Postby Guest » Sun Sep 25, 2005 7:16 am

PaulFox, if i understand correctly you are using a nightly branch build so correct operation is to be expected, the issue has only arisen in the trunk builds as of the 21st.
Guest
 

Postby Paulfox » Sun Sep 25, 2005 10:48 pm

Aaah - sorry Guest. Yes I've got 092305 BRANCH and wouldn't venture a "trunk" at this point since I've got 16 extensions and Noia Extreme Theme working great. I have downloaded the new Beta from mcm's link though - new features look COOL(!!) but I'll stick with "last final" AB+ for now. The multiple drag and whitelisting differentiation will be just fantastic, though. Soon, brothers and sisters . . . . soon! Woohoo! I've said it before - mcm for Governor.

I can't tell anyone what to use - and "trunks" are exciting and cutting edge and all that - but with 1.5b2 coming out October 5, and supposedly some 700 code changes/security fixes in the Sept 23 BRANCH - that's the one I'd recommend if you want maximum compatibility - or else try the trunk but really watch the extensions. Branches tend to be more "stable" as betas go - you can't really complain if a trunk upsets the apple cart.

That being said, thanks for the clarification and sorry I misinterpreted.
Paulfox
 

Postby mcm » Tue Sep 27, 2005 12:01 am

Anonymous wrote:No good on the hacked version here either i'm afraid..
If you get the latest nightly trunk and then try http://www.apple.com you should be able to see straight away whether it works.

Sorry about that I'm kind of busy at the moment so just addressed Boris's comments in Bug 309076 directly by removing the tag to disable XPCNativeWrappers so that it should be used automatically everywhere and coded work arounds or just disabled things that broke as a result. But if it doesn't work then when I have time I will download the latest trunk build and see what's going on (should be this weekend if not earlier).

Anonymous wrote:Just join the channel via command line even if it is not listed. Unforntunately the hacked version does not work for me.

Thanks Anonymous, indeed you're right. I'll need to have a look at it first so I know what to ask if I do get stuck but I might actually just contact Boris directly since he's the one who investigated the issue.
User avatar
mcm
 
Posts: 359
Joined: Sat Jun 10, 2006 2:36 am

Postby dfbb » Mon Oct 03, 2005 1:15 pm

Any news on the trunk problems?
dfbb
 

Postby Harald.L » Mon Oct 03, 2005 2:36 pm

dfbb wrote:Any news on the trunk problems?
The latest dev build 20051003 should fix it (cannot test it myself as I use an older nightly because of issues in the lastest ones).

Harald
Harald.L
 


Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: ShanaBrum and 10 guests