Click to hide doesn't really work properly

Posting here is no longer possible, please use the forum of a filter list project, such as EasyList

Click to hide doesn't really work properly

Postby alex111 » Mon Jun 23, 2014 10:08 pm

lately i've noticed that the feature that allowed to click on elements with adblock button to create filters isn't working anymore (element hiding in FF works properly https://adblockplus.org/elemhidehelper)
alex111
 

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:10 pm

what feature ? describe it as you know
ABP version ?
chrome version ?
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby gendalf » Mon Jun 23, 2014 10:14 pm

idk how it's called in english but i thought you would've guessed by my description :P
it's the second button (between stats and whitelist)

1.8.3, 36.0.1985.84 beta-m, but it didn't work in previous versions of chrome/abp for a while now

i'm mostly speaking about annoying messages like "you're using abp turn it off!" or adds that open pages in background when you click anywhere on the page, i can give examples but it's porn stuff :)

well this one isn't porn: http://www.crazygallery.info/
gendalf
 
Posts: 6
Joined: Mon Jun 23, 2014 10:09 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:25 pm

I don't understand what do you mean ... custom filters ? "add your own filters" tab ? (from options)

well, as for the sites that "detect" ABP or have popups, popunders, you have to report them and someone will find the right filter(s)
so, report even the porn sites :D

for that site add this filter:
Code: Select all
@@||crazygallery.info/ads/advertisement.js?*
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby gendalf » Mon Jun 23, 2014 10:31 pm

i mean this: https://adblockplus.org/images/265.png
Block Element - this feature doesn't work on many sites for me

thanks for the filter but it doesn't solve the problem - which is ability to creaty filters with one click on my own :/
Last edited by gendalf on Mon Jun 23, 2014 10:37 pm, edited 2 times in total.
gendalf
 
Posts: 6
Joined: Mon Jun 23, 2014 10:09 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:33 pm

oh, probably you are talking about clicking ABP icon, then click "block element". It does work for me but it isnt a general method to find a filter to get rid of detecting stuff ...
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:34 pm

give me an example site / page where the "block element" feature does not work
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby gendalf » Mon Jun 23, 2014 10:37 pm

it doesn't work at crazygallery and it doesn't work at pronpic.org (after you clicked on any picture) and many others :P

and also, where can i request adds to be added to easylist filters for example? (or temporary solutions for personal filters like the one above for crazygal)
Last edited by gendalf on Mon Jun 23, 2014 10:41 pm, edited 2 times in total.
gendalf
 
Posts: 6
Joined: Mon Jun 23, 2014 10:09 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:39 pm

well, I see, on that site ... but you don't even have the time to try it and like I said it does not even help you to find a useful filter

better open that site in firefox, open the blockable items list and analyze the requests for that site (quickly ...because it redirects to another site / page)

or

use inspect (chrome feature) to analyze the page ...
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:40 pm

you can ask at the easylist support forum:
http://forums.lanik.us/

or on the subforum
viewforum.php?f=2
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby gendalf » Mon Jun 23, 2014 10:40 pm

but what about http://pronpic.org/ block element doesn't work for me there :P and it doesn't redirect
gendalf
 
Posts: 6
Joined: Mon Jun 23, 2014 10:09 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:48 pm

try these
Code: Select all
@@||pronpic.org/ads/banner.jpg?*$image
||c.limon.biz^$popup
pronpic.org##[pluginspage="http://www.adobe.com/go/getflashplayer_ru"]
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 10:50 pm

sometimes it works but the filter is created on the wrong frame ... it's a bug in working ...but ! that method is not working to find the right filter in this detecting case
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Click to hide doesn't really work properly

Postby gendalf » Mon Jun 23, 2014 10:55 pm

it doesn't create anything for me it's just not selecting/highlighting anything, and if i click nothing happens
gendalf
 
Posts: 6
Joined: Mon Jun 23, 2014 10:09 pm

Re: Click to hide doesn't really work properly

Postby mapx » Mon Jun 23, 2014 11:03 pm

well, just created an issue on the bug tracker
https://issues.adblockplus.org/ticket/700

feel free to add other comments there
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Next

Return to Filters for Adblock Plus

Who is online

Users browsing this forum: No registered users and 6 guests