Problems with whitelisting YouTube channel

Everything about using Adblock Plus on Google Chrome

Problems with whitelisting YouTube channel

Postby Deezy » Mon Dec 05, 2016 3:04 pm

I have an Adblock Plus on Mac OS Chrome, and i want to whitelist my favourite channels on YouTube.

So I installed a Greasy Fork script, which adds youtube channel name to the url:
https://greasyfork.org/ru/scripts/4168- ... block-plus

Also I added this to my personal filters:
Code: Select all
@@||youtube.com/*&user=PewDiePie$document


The problem is that the whitelisting doesn't work from the first time, but works when I refresh the page.
Here are the steps:
1. Go to youtube.com
2. Go to video from whitelisted channel - there are no ads.
3. Refresh the page - ads appears.
4. Go to video from not whitelisted channel - ads are still there.
5. Refresh the page - ads disappears.

It's like the filter is working with a 1 page delay.
The same thing happens when I don't use greasy fork and just whitelist a list of urls.

Is there a way to fix this?
Deezy
 
Posts: 2
Joined: Mon Dec 05, 2016 2:54 pm

Re: Problems with whitelisting YouTube channel

Postby mapx » Mon Dec 05, 2016 3:15 pm

User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: Problems with whitelisting YouTube channel

Postby Deezy » Mon Dec 05, 2016 3:37 pm

I tried to add
Code: Select all
@@||youtube.com^$stylesheet
, but it didn't helped.
Is there a way to bypass this issue?
Deezy
 
Posts: 2
Joined: Mon Dec 05, 2016 2:54 pm


Return to Adblock Plus for Chrome support

Who is online

Users browsing this forum: No registered users and 7 guests