Domain Option Not Working

Everything about using Adblock Plus on Google Chrome

Domain Option Not Working

Postby Cardinal System » Thu Apr 25, 2019 2:50 am

I am making my first filter list, and I am having some trouble...

This is one of my lines:
Code: Select all
||static.vrv.co^$media,xhr,domain=crunchyroll.com

For whatever reason, it is not blocking the domain static.vrv.co as intented. I'm not sure what I'm doing wrong. It doesn't block the domain on crunchyroll, but it does block it on this site:
Code: Select all
https://static.vrv.co/houseads/Black_Friday_V2_15_House_480p.mp4
. :x

The AdBlock tutorial (https://adblockplus.org/filters#options) said that the domain option only blocks the request if the specified domain is the request's origin, however this seems to have the opposite effect.

The rest of my filter list is here (if it helps): https://raw.githubusercontent.com/TheCardinalSystem/Cruncyroll-Filter-List/master/english.txt

Anyone think they can help?
Cardinal System
 
Posts: 2
Joined: Thu Apr 25, 2019 2:32 am

Re: Domain Option Not Working

Postby mapx » Thu Apr 25, 2019 11:09 am

for ABP
Code: Select all
||static.vrv.co^$media,xmlhttprequest,domain=crunchyroll.com


"xhr" abbreviation is used in other adblocker: ublock origin

Don't use 2 adblockers together.

Provide crunchyroll video page where you tested the filter
User avatar
mapx
 
Posts: 21945
Joined: Thu Jan 06, 2011 3:01 pm

Re: Domain Option Not Working

Postby Cardinal System » Thu Apr 25, 2019 7:43 pm

mapx wrote:for ABP
Code: Select all
||static.vrv.co^$media,xmlhttprequest,domain=crunchyroll.com


"xhr" abbreviation is used in other adblocker: ublock origin

Don't use 2 adblockers together.

Provide crunchyroll video page where you tested the filter


Now I know what XHR stands for :P

The filter still doesn't work. I am testing it on this page: https://www.crunchyroll.com/the-helpful-fox-senko-san/episode-2-dont-be-shy-now-783550. I am wondering if the media option even exists in ABP...
Cardinal System
 
Posts: 2
Joined: Thu Apr 25, 2019 2:32 am

Re: Domain Option Not Working

Postby mapx » Thu Apr 25, 2019 8:01 pm

1. there is no media request for vrv.co
2. there is no static.vrv.co xhr request

Look into uBo logger or ABP logger and you'll get the same thing
User avatar
mapx
 
Posts: 21945
Joined: Thu Jan 06, 2011 3:01 pm


Return to Adblock Plus for Chrome support

Who is online

Users browsing this forum: Google [Bot] and 12 guests