Page 1 of 1

ABP version 3.6.3 needed

PostPosted: Sun Nov 03, 2019 2:40 pm
by raph3r
Hi Forumers!

I need the ABP 3.6.3 as I work on MS Vista and the last supported version of Google Chrome is 49. Where can I get it from?
The only available version of ABP is 3.7 which supports Google Chrome from version 51.

--
Rafael

Re: ABP version 3.6.3 needed

PostPosted: Mon Nov 04, 2019 3:59 pm
by sbell
Hi there!

Try this link https://downloads.adblockplus.org/devbu ... luschrome/

Feel free to contact us if you have any more questions!

Thanks
Shannon
ABP Support Team