Page 1 of 1

Disable clipboard manipulations - need a white list option

PostPosted: Sun May 27, 2012 5:06 pm
by ramicohen
Hi

The add-on "Disable clipboard manipulations" is very useful but sometimes it is important to disable it on certain websites. For example, Google Docs is one place where copy/paste operations are part of the normal workflow. It would be nice to have some sort of a white list feature, hopefully in a similar fashion to AdBlock plus which is very convenient to use (disable on page, disable on website).

Another option is having a subscription list, again like adblock plus, for known websites that need copy/paste.

Thank you

Rami

Re: Disable clipboard manipulations - need a white list option

PostPosted: Mon May 28, 2012 3:49 pm
by vinny86
Just out of curiosity :D
I don't use Google Docs, but is there a situation where the website automatically inserts text apart from which the user has selected ?

Re: Disable clipboard manipulations - need a white list option

PostPosted: Fri Jun 22, 2012 2:15 pm
by Wladimir Palant
I am going to remove that extension soon given that there is a dom.event.clipboardevents.enabled preference in Firefox 13 now. It was a proof of concept that isn't required any more.

Re: Disable clipboard manipulations - need a white list option

PostPosted: Fri Oct 11, 2013 10:31 am
by trlkly
Yes, it is, if we want to be able to have a whitelist, which, unfortunately, we seem to need. I've encountered problems with this on many WYSIWYG editors. It affects the ability to copy and paste from them at all, as well as prevents use of Ctrl-Z to fix deletions of text.

Furthermore, Adblock Plus filters are failing on the job of handling these without the need for such an extension. This practice started in 2010, and yet many websites that still use this are still unblocked, despite the decision back with Tynt.com to block this sort of thing. So my assumption is that simply blocking scripts is not working anymore.

We need the ability to block this intrusion without also blocking all WSIWYG editors from functioning correctly. Please do not delete this, but rather build a much better extension.