Page 1 of 2

Adblock Plus does not work firstly when open subpages

PostPosted: Wed Sep 18, 2013 5:55 pm
by Enig123
Adblock Plus for Opera 1.5.5, Opera 16.0.1196.73

When open a subpage from main page, Adblock Plus will not work in the first place, ads still pop up. After refresh the subpage, it started to work.

I guess it's a bug of Adblock Plus.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Thu Sep 19, 2013 10:19 am
by MonztA
You mean when you open Opera and the website that opens automatically has unblocked ads?

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Fri Sep 20, 2013 5:15 am
by guesst
I'm having a similar issue, but it mostly has to do with pages that open as pop ups.
For instance on this site http://live24.gr , radio stations open as pop-ups and all show ads when you first open them. Even if you middle click and open them inside a tab they still show ads. Refreshing the pop-up, or the tab removes the ads.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Fri Sep 20, 2013 7:11 pm
by Enig123
MonztA wrote:You mean when you open Opera and the website that opens automatically has unblocked ads?


No. It's a page opened when I clicked the link of the main page.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Fri Sep 20, 2013 7:14 pm
by Enig123
To be more specific, the Adblock Plus failed to apply to left-clicked popup subpages. It do work with right-click then opened subpages.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Wed Sep 25, 2013 1:42 pm
by Keitan
Same problem for me. If I open a link (with feedly for example), adblock doesn't work on this page.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Fri Sep 27, 2013 7:09 pm
by Enig123
Let me get things more clear.

There's two ways to open an url link from main page with Opera or any other browsers: 1, left click the link; 2, right click the link then click 'Open Link in New Tab'.

What I've found the problem is, at least for some website, when opened link with method 1, abp may not be fully applied to the newly opened page, while with method 2, there's no problem at all.

I hope that will give some hints for the developers to find the potential bugs.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Sat Sep 28, 2013 12:10 am
by guesst
Also, I tried the other Adblock and found out that the same problem exists. Maybe it has something to do with Opera then?

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Mon Sep 30, 2013 10:01 pm
by Enig123
Opera dose not responsible for ad block features. So I guess it's a problem of Adblock itself.

Hope developers can fix it ASAP.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Fri Oct 18, 2013 11:13 am
by guest
Is this on the fix list, or should we just use Chrome?

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Fri Oct 18, 2013 9:53 pm
by quest(ion)
Another example: http://www.ampparit.com

Left click any news link here and notice that no ads are blocked in newly opened tab.
Right click and "Open link in new tab": everything works as it should.

Maybe this has something to do with target=_blank?

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Mon Mar 03, 2014 10:14 am
by guest
Any news on this? Is it an Opera specific issue? The problem exists on 21 dev last time I checked.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Mon Mar 03, 2014 10:18 am
by mapx
if you are talking about ads on startup pages this is an old chromium issue (the extensions are initialized after loading the startup pages)

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Mon Mar 03, 2014 11:02 am
by Guest
mapx wrote:if you are talking about ads on startup pages this is an old chromium issue (the extensions are initialized after loading the startup pages)


No... I'm talking about when you click certain link that open pop-ups, ads aren't blocked on them. Refreshing the pop-up blocks the ads. Chrome doesn't have this issue, I've tested it. Opera has this problem with both adblockers available (ABP and Adblock) that's why I'm guessing that it's an Opera specific issue. Apparently Opera does something in a different way than Chrome, in this case.

example url: live24.gr
just open a radio station. It opens in a pop-up window with ads, refreshing blocks them.

Same thing happened the other day when clicking the "watch on Youtube" button on an embedded video. The youtube page had ads, and needed a refresh to block them.

Re: Adblock Plus does not work firstly when open subpages

PostPosted: Wed Mar 05, 2014 8:15 pm
by snoack
I can reproduce that. However it seems to be fixed with one of my patches, which is currently under review.