Page 1 of 2

AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Fri Feb 10, 2017 11:50 am
by 8ball
I noticed that my forums homepage advert was not displaying on 1st visit to the homepage from another website, first I thought it was on chrome only? (have to refresh to get it too load...) well, I am now using Opera and I have installed AdblockPlus as the built in one doesnt allow me access to our Adsense account if I block Google (and have to put up with their ads on Youtube and Search) , so I disabled it and installed ABP on Opera to give me more control (disabled on my website)... low and behold the issue now happens on Opera AND Chrome... this must be related to the coding on ABP for these types of browsers..

Symptom:
when i visit the homepage with ABP installed (but disabled on our website) the advert doesn't display unless I refresh the page (Chrome and Opera only), it may display loading it from within the site but not coming from another website to the homepage it does not!


- it works fine on Firefox but that is slow as hell and burns through writes like nobody's business on my SSD

cant say I'm happy about it as I can see from our AdSense account that the advert on the homepage is only getting about 3% of all impressions which doesn't seem right to me and the fact this happens tells me why, this tells me that most people that visit with ABP installed on Chrome or Opera (and even have it disabled on this website) are having that advert blocked on the first landing of the homepage, but then able to view the rest of the ads on the forum as they work fine, as the homepage is the landing page for the site you would expect this number to be only slightly less than homepage impressions...

can anyone help resolve this problem please?

website: [no follow]
Code: Select all
http://www.thetechforum.co.uk


thanks

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Fri Feb 10, 2017 11:59 am
by mapx
yeah, already reported
https://adblockplus.org/forum/viewtopic.php?p=162845#p162845

an issue was added on the bug tracker
https://issues.adblockplus.org/ticket/4599

a patch is under review
https://codereview.adblockplus.org/29362605/

if you want to add your comments on that ticket (4599) just register an account there and post your thoughts

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Fri Feb 10, 2017 12:22 pm
by 8ball
Thanks for your reply

I noticed this problem with Chrome months ago, I thought it was my problem (website) but now I know its not:

theres been nothing happening on that ticket for months? I hope the dev hasnt just sidelined it?

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Fri Feb 10, 2017 2:12 pm
by mapx
waiting for ...review (2 weeks ago the last change)
see https://codereview.adblockplus.org/29362605/

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Fri Feb 10, 2017 8:56 pm
by mapx
probably the ABP devs are waiting also for some chrome's devs reaction
https://bugs.chromium.org/p/chromium/is ... ?id=665843

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Mon Mar 06, 2017 9:18 pm
by varon
Good post ty.Love addblock clean serfing in internet. :)

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Sun Mar 12, 2017 4:22 pm
by 8ball
still no fix with this?

Ive had to dump ABP because of issues, Im now getting forum users reporting that my popup asking users to disable ABP is still appearing when ABP is disabled on my website?? - I cant replicate the issue with Opera, Chrome or Firefox... but in Chrome and Opera the issue I mention above still remains

anyone else having issues recently?

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Sun Mar 12, 2017 4:24 pm
by mapx
it was fixed in the dev build, for the stable build wait for the next tuesday

dev build:
https://chrome.google.com/webstore/deta ... ifjjdoepkn

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Sun Mar 12, 2017 5:26 pm
by 8ball
a user on my forum reports that its still causing the disable adblock notice to appear even though its set to be disabled on my website? this is on firefox 52..? i can replicate it on FF52 myself... you dont know what could be the cause do you?

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Sun Mar 12, 2017 5:31 pm
by mapx
I'm talking here on opera forum about the ABP for chromium. Test the dev build in chrome.
For firefox, provide the steps to reproduce the issue using real example site.

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Sun Mar 12, 2017 5:38 pm
by 8ball
sorry just realised my mistake.. i CANT replicate the issue myself, just tested on FF52 with ABP enabled but set to disabled on my website www.thetechforum.co.uk , the advert loads as it should (although still doesnt in chrome or opera upon first visit, refresh causes it to load) - either way I cant get the 'disable adblock' banner to appear on FF52 when its disabled...

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Sun Mar 12, 2017 5:45 pm
by smed79

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Sun Mar 12, 2017 8:51 pm
by 8ball


we dont have unfriendly adverts, only one vertical banner down the side on the homepage and one horizontal banner at the top of each topic... never more than 1 advert per page either

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Thu Mar 30, 2017 12:39 pm
by Sandy88
Hi..........thanks for the information I have come back very useful

Re: AdBlockPlus ..Blocking Ads even when disabled

PostPosted: Thu May 18, 2017 6:06 pm
by 8ball
this is still happening with ABP ? originally it was only the first visit to my homepage with ABP off and the advert was blocked?

but now its EVERY visit to the homepage http://www.thetechforum.co.uk the advert is blocked with ABP off on this domain

why does this happen and why is it taking several months for the fix (mentioned above) to be pushed through?

thanks

Image