Avoiding the first run page to show up in Internet Explorer

Place to exchange experience about rolling out Adblock Plus to many computers, preconfiguring the extension etc.

Avoiding the first run page to show up in Internet Explorer

Postby p_hill » Tue Aug 19, 2014 4:17 pm

As I receive quite some questions on how to avoid the first run page to show up in Adblock Plus (ABP) for Internet Explorer when mass-deploying it, here is how to do so:

  1. First of all, you should do one sample installation of Adblock Plus for Internet Explorer.
  2. Go to C:\Users\IEUser\AppData\LocalLow\Adblock Plus for IE\ (of course, you need to adapt this to your local drive/user names)
  3. Make sure to deploy the files prefs.json and patterns.ini to every new ABP for IE installation, into the same folder

Please note that the file prefs.json contains the current installation's version number, which in some cases can trigger certain behaviour. To make sure, that this will be correct, please update this file whenever you centrally deploy Adblock Plus with the file belonging to the newly installed version. On updates, the file will be updated by ABP itself. If your users have sufficient permissions, updates that will be checked for on automated base can be installed by the user himself. If they don't have sufficient permissions, you might want to avoid the update notifications by blocking the update request URL in your firewall:
Code: Select all
https://update.adblockplus.org/adblockplusie/update.json
(Please note that there will be certain parameters added, usually ?type=0 for automatic updates and ?type=1 for manual checks).

Filter lists will still be updated with this URL blocked.
p_hill
ABP QA Manager
 
Posts: 431
Joined: Mon Feb 03, 2014 6:26 pm
Location: Cologne

Re: Avoiding the first run page to show up in Internet Explorer

Postby McFa » Thu Aug 28, 2014 3:11 pm

When are you going to add the parameters to disable the automatic updates?
McFa
 

Re: Avoiding the first run page to show up in Internet Explorer

Postby p_hill » Thu Aug 28, 2014 3:49 pm

We just started the information gathering phase, so any kind of implementation change is still a bit far from now. Let's hope we can do some within this year.
p_hill
ABP QA Manager
 
Posts: 431
Joined: Mon Feb 03, 2014 6:26 pm
Location: Cologne

Re: Avoiding the first run page to show up in Internet Explorer

Postby df » Tue Sep 23, 2014 4:41 pm

I've been looking into how to copy these files using SCCM without the need of much intervention on our part. The solution that I've come across is a little messy, but it works. Basically, you create a second application using the guidelines laid out here: http://blog.configmgrftw.com/copying-fi ... configmgr/ and then set that as a dependency of the ABP application. Once the ABP finishes, the dependency application that just copies the files should run. Has anyone found a more elegant solution?
df
 

Re: Avoiding the first run page to show up in Internet Explorer

Postby Matze » Mon Sep 29, 2014 10:45 am

Hi df,

can you please explain why you've created a second / a dependency App - rather than incorporating the files in the ABP one itself?

Thank you!
Matze
User avatar
Matze
ABP Developer
 
Posts: 8
Joined: Thu Aug 14, 2014 9:41 am

Re: Avoiding the first run page to show up in Internet Explorer

Postby bbain » Thu Dec 18, 2014 2:57 am

Can you copy the files to the default user folder to have them automatically deployed to all users on a computer?

Brent
bbain
 

Re: Avoiding the first run page to show up in Internet Explorer

Postby kjstech » Thu Oct 01, 2015 4:09 pm

According to this post: https://adblockplus.org/development-bui ... or-install
The new 1.5 version has some registry settings to disable the first run page and also automatic updates.

It says:
To disable the first run page add this value to the registry:

Windows Registry Editor Version 5.00
[HKCU\Software\AdblockPlus]
"suppress_first_run_page"="true"
Similarly, to disable automatic updates, add:

Windows Registry Editor Version 5.00
[HKCU\Software\AdblockPlus]
"disable_auto_updates"="true"


My issue is I do not know what kidn of value those are? Binary, DWORD, string, expand_sz, multi_sz? If I just put those in a txt file and save it as a .reg, run it, click yes, then look in Regedit, none of those values show up in that location. I suspect because maybe the type is not specified. Help?
kjstech
 
Posts: 7
Joined: Thu Oct 01, 2015 3:27 pm

Re: Avoiding the first run page to show up in Internet Explorer

Postby bkcali22 » Tue Oct 27, 2015 3:59 pm

Did you ever figure out what type of reg value these need to be set as?
bkcali22
 
Posts: 4
Joined: Thu Oct 22, 2015 10:29 pm

Re: Avoiding the first run page to show up in Internet Explorer

Postby axie » Wed Oct 28, 2015 4:33 pm

bkcali22 wrote:Did you ever figure out what type of reg value these need to be set as?

This is simply a string value.
axie
 
Posts: 5
Joined: Mon Oct 19, 2015 5:38 pm

Re: Avoiding the first run page to show up in Internet Explorer

Postby bkcali22 » Wed Nov 04, 2015 4:58 pm

I have it set as disable_auto_updates REG_SZ with a value of true and it is still prompting for updates
bkcali22
 
Posts: 4
Joined: Thu Oct 22, 2015 10:29 pm

Re: Avoiding the first run page to show up in Internet Explorer

Postby Jeff d » Mon Feb 22, 2016 11:05 pm

I just used these two registry values deployed via GPO and they worked fine.
Jeff d
 
Posts: 4
Joined: Mon Feb 22, 2016 10:50 pm


Return to Large scale deployments of ABP

Who is online

Users browsing this forum: No registered users and 3 guests