Page 1 of 2

Adblock for Edge fail to add subscription

PostPosted: Sat May 07, 2016 8:51 am
by knight820
Since I cannot find the edge support page and the extension options directed me here, I post on this page.
In MS Edge, build 14332, I installed adblock plus from the store. After I turned it on, I want to add subscription list such as China easy list into the extension.
However, I found it had no response when I press the "Add filter Subscription" button.
Thank you for your support and hope you will fix it.

Re: Adblock for Edge fail to add subscription

PostPosted: Sat May 07, 2016 9:16 am
by mapx
- moved in the right section
- however ABP for edge seems to be available for now only for the windows insiders:
http://www.windowscentral.com/adblock-a ... dows-store

Re: Adblock for Edge fail to add subscription

PostPosted: Wed May 11, 2016 2:33 pm
by stetzen
Well, the purpose of insider users is to find bugs before the software becomes widely available, so it seems to be a valid bug report. And yes, I do see this bug as well, "Add filter subscription" button does nothing at the moment.

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 8:39 am
by rseiler
Oh, I thought it was just me. It's more than just that button though, isn't it?

No links or buttons in Options do anything at all beyond making the window jump a little bit in some cases.

I can't even see what filters are active, if any.

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 9:35 am
by mapx
see on the bug tracker if it was already reported, otherwise file an issue there:
https://issues.adblockplus.org

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 4:25 pm
by rseiler
That will take some time due to the volume of issues there.

Meanwhile, anyone confirming or denying that the page has major issues beyond "Add filter subscription" would be helpful.

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 4:32 pm
by mapx
this filtered link should show all the edge issues
https://issues.adblockplus.org/query?st ... r=priority

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 4:41 pm
by rseiler
OK, that's helpful, but even "Add filter subscription" isn't mentioned there, and it's definitely an issue. Whether anything beyond that on that page is also an issue is something that I'd like someone to confirm before adding to the tracker.

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 4:46 pm
by mapx
just file an issue there, eventually upload some screenshot. If it's already known will be closed as duplicate.

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 6:58 pm
by JWW
Running Insider build 14372 and ABP 0.9.2.0. For me 'Add Filter Subscription' enables a drop down providing a choice of additional lists but not including the normally default lists for tracking and malware that you're offered with ABP on startup in other browsers. I have been able to add EasyPrivacy and Fanboy's Annoyance List by clicking on the EasyList 'link' in Options which takes you to the EasyList website. Choosing to add another list directly from there works, i.e. installs in ABP for Edge. BTW, all other links / buttons seem to work.

I'm just curious to know why they aren't provided 'up front' as usual and where the Malware list is...

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 7:03 pm
by rseiler
OK, thanks, I kind of thought that it couldn't possibly be that non-functional. It's just a problem here then, though one that survives repeated uninstalls/reinstalls of the extension and even a complete Edge reset.

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 7:17 pm
by mapx
@JWW, I can't test myself, but if you go to
http://adblockplus.org/en/subscriptions

you'll see the malware list, try subscribe it from that site

Re: Adblock for Edge fail to add subscription

PostPosted: Wed Jun 29, 2016 9:09 pm
by JWW
Cheers! That worked.

Re: Adblock for Edge fail to add subscription

PostPosted: Thu Jun 30, 2016 12:22 am
by JWW
@rseiler This is a complete shot in the dark, but the only problems I've had with Edge are:

1) CCleaner seems to mess with it and until I uninstalled CCleaner yesterday I had all kinds of weird stuff going on with Edge.
2) Check that you're allowing cookies in Edge. Mysteriously that option in Edge reverted to 'Block all cookies' yesterday as well. All kinds of things weren't working and I had no idea what was causing it.

Probably you have neither issue but I honestly cant think of anything else.

Re: Adblock for Edge fail to add subscription

PostPosted: Fri Jul 01, 2016 9:18 pm
by rseiler
No, it's neither of those things, but I did notice something fundamental today when loading the extension in a VM installation: it looks radically different than what I've been seeing. That is, Options comes up in its regular (meaning what I've seen in other browsers) tabbed UI.

But in my main install, it doesn't. Instead, all options come up on one page. It's the same page that you can see for an instant before the tabbed UI loads, especially if you've just run the browser fresh. Maybe it's CSS failing, I'm not sure.
http://screencast.com/t/AqrZgzm1q

I have seen some other reports about this in the Feedback tool, so it's not just unlucky me.