Adblock Disappeared from Edge

Everything about using Adblock Plus on Microsoft Edge

Adblock Disappeared from Edge

Postby TurtleBeach » Thu Feb 13, 2020 1:57 am

Sometime over the last two days, AdBlock Plus disappeared from Edge. When I attempt to download again, I am redirected to the Microsoft store, which says that AdBlock Plus is installed, so I cannot download again. However, it does not appear in the Edge title bar / address bar, nor does it appear in Control Panel.

How do I restore AdBlock Plus?

Thanks
TurtleBeach
 

Re: Adblock Disappeared from Edge

Postby sbell » Thu Feb 13, 2020 8:03 pm

Hi @TurtleBeach!

Check out the instructions in this link on showing and hiding the icon https://help.eyeo.com/en/adblockplus/hi ... n?b5e9f793. Let me know if this helps.

Thanks
Shannon
ABP Support Team
sbell
ABP Technical Support Specialist
 
Posts: 511
Joined: Wed Jul 05, 2017 8:08 pm

Re: Adblock Disappeared from Edge

Postby BonnieB » Fri Feb 14, 2020 2:31 am

Similar thing happened to me.

Last night (2-12-2020) I got a popup that said something about AdBlock Plus just installed an update and that AdBlock Plus was turned off. Click the button to turn it back on or click another button to leave it turned off.

I clicked the button to turn it back on. I did *not* notice if it was in Edge toolbar before I did that … but it was definitely *not* in my toolbar after! I clicked the Edge Extensions and AdBlock Plus was nowhere to be found! I was afraid that I had clicked on a spoofed ABP popup and that I may have gotten a virus.

This morning I got another popup, but I just closed the browser.

This afternoon, I went to look at the Edge Extensions and AdBlock Plus is back, waiting for me to enable it. I am hesitant to do that, because late yesterday one of our company servers had an attack by the Devos Ransomware. And I had been VPN'd into that network right about that time. Everyone is pointing their finger at me!! =0( But, I just finished using Malwarebytes to scan by computer, and while I *do* have some malware, it is *not* the Devos Ransomware.

I want to be 100% sure it wasn't an AdBlock Plus spoof that I clicked on and that I can safely enable my ABP extension now.

Any advice?
~~Bonnie
BonnieB
 

Re: Adblock Disappeared from Edge

Postby Joly » Fri Feb 14, 2020 3:26 am

The same thing happened to me...no visable sign of ADP adblocker and it is not blocking either. I get the message I 'own' the program, but it doesn't launch, even when I select the launch button. Any fix yet?
Joly
 

Re: Adblock Disappeared from Edge

Postby Joly » Fri Feb 14, 2020 3:30 am

Interesting, the same thing has happened to me on the same date, 2/13/20...and it isn't functioning either.
Joly
 

Re: Adblock Disappeared from Edge

Postby TurtleBeach » Fri Feb 14, 2020 3:56 am

@Shannon,
Thanks for replying, though your suggestion did not help. Nothing (no options to do anything) appear when I right click anywhere in the area after (to the right of) the address bar.

I did, however, dig deeper into the extensions menu, and there found that AdBlock appeared to be installed, but not turned on. Unfortunately, turning it on also did not help - the icon did not appear after the address bar, and the setting seems not to persist across closing/reopening the browser. According to ABP extension information, it is 0.9.19, installed (it seems automatically, since I did not explicitly reinstall or update anything) on February 12 2020. None of the controls (check boxes for Show Button … , Allow for In Private, Allow Notifications) are available, nor are the Options link or the Uninstall button. I have deleted everything in storage, though I prefer not to delete cookies because those that I allow I allow for good reason.

On the machine with issues, Edge reports:
Microsoft Edge 44.18362.449.0
Microsoft EdgeHTML 18.18363
Winver reports Version 1909 (OSBuild 18363.592)

On another machine, newer hardware with a recently (late last year) installed version of Win 10 Pro, Edge reports:
Microsoft Edge 44.18362.449.0
Microsoft EdgeHTML 18.18362 (an older version), and ADB works on that machine (same ABP version 0.9.19 - installed 12/21/2019).
Winver reports Version 1903 (OSBuild 18362.657)

This all leads me to suspect the combination of new Edge and new Win10, although as best I can tell the major 'feature' update to 1909 occurred in November last year, and ABP was working until a few days ago. Hope this helps.
Jack
TurtleBeach
 

Re: Adblock Disappeared from Edge

Postby TurtleBeach » Mon Feb 17, 2020 4:57 pm

While I have no explanation for the mysterious behavior, I eventually was able to remove ABP, and reinstall it. After re-installing, ABP is working again with Edge.
TurtleBeach
 

Re: Adblock Disappeared from Edge

Postby BonnieB » Wed Feb 19, 2020 7:25 pm

Well, I decided to bite the bullet and went ahead and re-enabled the ABP extension. Malwarebytes did *not* go nuts and tell me that I had malware (which I was afraid might happen because of my fear of having been "spoofed" by a fake ABP popup), so I guess those popups were legit! ABP is now working fine.

@TurtleBeach, my Win 10 is at an earlier version than yours that has a problem, but the same as yours that does not have a problem (1903, OSBuild 18362.657) … I hope you find a resolution to your issue!!
BonnieB
 

Re: Adblock Disappeared from Edge

Postby sbell » Thu Feb 20, 2020 8:05 pm

Hi all! Many apologies for the delay. We weren't able to reproduce the issue on our end. This was certainly strange behavior. :-/ We will continue to keep an eye out for anything similar. Glad to hear reinstall resolved the issued. Have a GREAT week!

Thanks
Shannon
ABP Support Team
sbell
ABP Technical Support Specialist
 
Posts: 511
Joined: Wed Jul 05, 2017 8:08 pm


Return to Adblock Plus for Edge support

Who is online

Users browsing this forum: No registered users and 0 guests