[579] IE 10/IE 11 crash when using Adblock Plus

Everything about using Adblock Plus on Internet Explorer

[579] IE 10/IE 11 crash when using Adblock Plus

Postby Emka1001 » Sun Feb 09, 2014 5:47 pm

Hello,

When navigating to the following site:
http://www.sony.pl/support/pl/product/S ... EW/updates
the Internet Explorer 10 and 11 crash when using Adblock.

This issue occurs on Windows 8 (IE 10) and Windows 8.1 (IE 11). This occurs on two different PCs.

The Adblock version is 1.1.0.0 on both. The IE add-ons were disabled one by one and Adblock was deemed to be the culprit. All the latest Windows Updates are applied to both PCs. Adding sony.pl site to list of "unblocked sites" has no effect.

The information on the crash from Event Viewer is:
Code: Select all
Log Name:      Application
Source:        Application Error
Date:          2014-02-09 16:39:28
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MKLAP
Description:
Faulting application name: IEXPLORE.EXE, version: 11.0.9600.16384, time stamp: 0x52157231
Faulting module name: ntdll.dll, version: 6.3.9600.16408, time stamp: 0x523d45fa
Exception code: 0xc0000005
Fault offset: 0x0001e12c
Faulting process id: 0xe94
Faulting application start time: 0x01cf25ad1ce7470c
Faulting application path: C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 5bc8d669-91a0-11e3-bf35-001dd9fd390a
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-02-09T15:39:28.000000000Z" />
    <EventRecordID>29351</EventRecordID>
    <Channel>Application</Channel>
    <Computer>MKLAP</Computer>
    <Security />
  </System>
  <EventData>
    <Data>IEXPLORE.EXE</Data>
    <Data>11.0.9600.16384</Data>
    <Data>52157231</Data>
    <Data>ntdll.dll</Data>
    <Data>6.3.9600.16408</Data>
    <Data>523d45fa</Data>
    <Data>c0000005</Data>
    <Data>0001e12c</Data>
    <Data>e94</Data>
    <Data>01cf25ad1ce7470c</Data>
    <Data>C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE</Data>
    <Data>C:\WINDOWS\SYSTEM32\ntdll.dll</Data>
    <Data>5bc8d669-91a0-11e3-bf35-001dd9fd390a</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>
Emka1001
 
Posts: 1
Joined: Sun Feb 09, 2014 5:40 pm

Re: IE 10/IE 11 crash when using Adblock Plus

Postby Oleksandr Paraska » Mon Feb 10, 2014 5:31 pm

Thank you for reporting. We have indeed found that ABP for IE does crash sometimes when running within Enhanced Protected Mode. We have fixed that issue and it should be rolled out in the next update.
Oleksandr Paraska
ABP Developer
 
Posts: 19
Joined: Wed Jun 19, 2013 2:49 pm

Re: IE 10/IE 11 crash when using Adblock Plus

Postby anagrammar » Sat May 17, 2014 7:18 pm

I had the same problem. I finally found a way to run adblock plus without crashing ie. Combining adblock plus with avast security extension (not their adblock which is inferior) with all tracking filters turned on seems to stabilize adblock plus in ie.
anagrammar
 

Re: IE 10/IE 11 crash when using Adblock Plus

Postby -Px- » Wed May 21, 2014 10:53 pm

I have similar problem, but in my case AdblockPlusEngine.exe is crashing with ExceptionCode: c0000005 (Access violation)
Is there a way for helping to debug this issue? Adblock for IE 1.1 installed, development version says that it is older than installed version, and I don't see public symbols available for neither of this versions so stack trace looking completely useless:
0:007> k
Child-SP RetAddr Call Site
00000000`2362ed48 00000000`9fe59841 0x221b84b
00000000`2362ed50 00000000`9fe45a61 0x9fe59841
00000000`2362ed58 00000000`2362ed98 0x9fe45a61
00000000`2362ed60 00000000`02225e4a 0x2362ed98
00000000`2362ed68 1baffed0`0baffedf 0x2225e4a
00000000`2362ed70 00000000`9fe45de9 0x1baffed0`0baffedf
00000000`2362ed78 00000000`9fe59841 0x9fe45de9
00000000`2362ed80 00000000`02225d81 0x9fe59841
00000000`2362ed88 00000008`00000000 0x2225d81
00000000`2362ed90 00000000`00000000 0x00000008`00000000
and exception analysis does not give much useful information, but I'm providing it anyway:
Code: Select all
FAULTING_IP:
+0
00000000`0221b84b 488b50ff        mov     rdx,qword ptr [rax-1]

EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 000000000221b84b
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

CONTEXT:  0000000000000000 -- (.cxr 0x0;r)
rax=1baffed00baffedf rbx=0000000000000001 rcx=0000000000000000
rdx=000000000221b820 rsi=000000009fe45a61 rdi=000000009fe59841
rip=000000000221b84b rsp=000000002362ed48 rbp=000000002362ed58
r8=000000009fe45de9  r9=0000000000000001 r10=00000000231f3308
r11=0000000000000202 r12=0000000100000000 r13=0000000000338ef8
r14=000000009fe45391 r15=000000002362f040
iopl=0         nv up ei pl nz na pe nc
cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010200
00000000`0221b84b 488b50ff        mov     rdx,qword ptr [rax-1] ds:1baffed0`0baffede=????????????????

FAULTING_THREAD:  000000000000181c

DEFAULT_BUCKET_ID:  INVALID_POINTER_READ

PROCESS_NAME:  AdblockPlusEngine.exe

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  ffffffffffffffff

READ_ADDRESS:  ffffffffffffffff

FOLLOWUP_IP:
unknown!noop+0
00000000`9fe59841 58              pop     rax

NTGLOBALFLAG:  0

APPLICATION_VERIFIER_FLAGS:  0

APP:  adblockplusengine.exe

ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

IP_ON_HEAP:  000000009fe59841
The fault address in not in any loaded module, please check your build's rebase
log at <releasedir>\bin\build_logs\timebuild\ntrebase.log for module which may
contain the address if it were loaded.

PRIMARY_PROBLEM_CLASS:  INVALID_POINTER_READ

BUGCHECK_STR:  APPLICATION_FAULT_INVALID_POINTER_READ

FRAME_ONE_INVALID: 1

LAST_CONTROL_TRANSFER:  from 000000009fe59841 to 000000000221b84b

STACK_TEXT: 
00000000`2362ed48 00000000`9fe59841 : 00000000`9fe45a61 00000000`2362ed98 00000000`02225e4a 1baffed0`0baffedf : 0x221b84b
00000000`2362ed50 00000000`9fe45a61 : 00000000`2362ed98 00000000`02225e4a 1baffed0`0baffedf 00000000`9fe45de9 : 0x9fe59841
00000000`2362ed58 00000000`2362ed98 : 00000000`02225e4a 1baffed0`0baffedf 00000000`9fe45de9 00000000`9fe59841 : 0x9fe45a61
00000000`2362ed60 00000000`02225e4a : 1baffed0`0baffedf 00000000`9fe45de9 00000000`9fe59841 00000000`02225d81 : 0x2362ed98
00000000`2362ed68 1baffed0`0baffedf : 00000000`9fe45de9 00000000`9fe59841 00000000`02225d81 00000008`00000000 : 0x2225e4a
00000000`2362ed70 00000000`9fe45de9 : 00000000`9fe59841 00000000`02225d81 00000008`00000000 00000000`00000000 : 0x1baffed0`0baffedf
00000000`2362ed78 00000000`9fe59841 : 00000000`02225d81 00000008`00000000 00000000`00000000 00000000`2362ee30 : 0x9fe45de9
00000000`2362ed80 00000000`02225d81 : 00000008`00000000 00000000`00000000 00000000`2362ee30 00000000`02207a19 : 0x9fe59841
00000000`2362ed88 00000008`00000000 : 00000000`00000000 00000000`2362ee30 00000000`02207a19 00000000`00000000 : 0x2225d81
00000000`2362ed90 00000000`00000000 : 00000000`2362ee30 00000000`02207a19 00000000`00000000 00000000`00000000 : 0x00000008`00000000


STACK_COMMAND:  .cxr 0x0 ; kb

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  unknown!noop+2362ed48

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: unknown

IMAGE_NAME:  unknown

DEBUG_FLR_IMAGE_TIMESTAMP:  0

FAILURE_BUCKET_ID:  INVALID_POINTER_READ_c0000005_unknown!noop

BUCKET_ID:  X64_APPLICATION_FAULT_INVALID_POINTER_READ_unknown!noop+2362ed48

Making memory minidump with Procdump and send it via PM next time when it happens, will help to investigate the source of the problem?
-Px-
 
Posts: 2
Joined: Tue May 20, 2014 8:29 pm

Re: IE 10/IE 11 crash when using Adblock Plus

Postby -Px- » Thu May 29, 2014 9:13 pm

Somebody? Anybody?
-Px-
 
Posts: 2
Joined: Tue May 20, 2014 8:29 pm

Re: IE 10/IE 11 crash when using Adblock Plus

Postby mapx » Thu May 29, 2014 9:27 pm

you could file an issue on the bug tracker
https://issues.adblockplus.org
User avatar
mapx
 
Posts: 21740
Joined: Thu Jan 06, 2011 3:01 pm

Re: IE 10/IE 11 crash when using Adblock Plus

Postby mapx » Fri May 30, 2014 9:41 am

User avatar
mapx
 
Posts: 21740
Joined: Thu Jan 06, 2011 3:01 pm

Re: [579] IE 10/IE 11 crash when using Adblock Plus

Postby rononholiday » Tue Jul 08, 2014 6:43 pm

explorer 10 crashes when linked pdf files selected disable adblock plugin solves problem.
rononholiday
 

Re: [579] IE 10/IE 11 crash when using Adblock Plus

Postby dhjui » Sat Aug 20, 2016 8:32 pm

finally i found the fix
Code: Select all
http://www.deskdecode.com/internet-explorer-has-stopped-working/
dhjui
 
Posts: 2
Joined: Sun May 22, 2016 12:32 am


Return to Adblock Plus for Internet Explorer support

Who is online

Users browsing this forum: No registered users and 8 guests