[Done] Removing support for Firefox 2 & Co

Discussion of possible Adblock Plus features and changes. New topics cannot be created, interesting suggestions will be moved from General forum.

Moderators: greiner, fhd

[Done] Removing support for Firefox 2 & Co

Postby Wladimir Palant » Fri Apr 24, 2009 10:06 pm

I started removing support for browsers based on Gecko 1.9.0.8 and below. The reason why I don't want to support Gecko 1.9.0.8 and 1.9.1b3 (aka Firefox 3.0.8 and 3.1b3) is bug 416942 - getting element hiding to work there requires a totally different mechanism. This means that in Adblock Plus 1.1 (which will still take a while) the lowest supported versions will be:

* Firefox 3.0.9
* SeaMonkey 2.0b1
* Thunderbird 3.0b3
* Songbird 1.2.0b1
* Prism 1.0b1

Flock, Midbrowser and Conkeror stay unofficially supported, I am not going to do any testing in those. eMusic Remote and K-Meleon will no longer be supported - these are still based on Gecko 1.8.1 and no new version seems to be coming up.
Last edited by Wladimir Palant on Wed Jun 03, 2009 2:33 am, edited 5 times in total.
Wladimir Palant
ABP Developer
 
Posts: 8332
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Postby Wladimir Palant » Fri Apr 24, 2009 10:08 pm

Element hiding support for old browsers is already gone and I am replacing the find bar in preferences by browser's standard widget right now. Looks good - the build is already 16kB smaller than Adblock Plus 1.0.2 (largely because I had to keep around translations for findbar that are now being taken from the browser).
Wladimir Palant
ABP Developer
 
Posts: 8332
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Postby Wladimir Palant » Tue May 05, 2009 8:28 pm

I think this can be considered done. Most code that is no longer necessary has been removed.
Wladimir Palant
ABP Developer
 
Posts: 8332
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Re: [Done] Removing support for Firefox 2 & Co

Postby Gunther Nikl » Fri May 15, 2009 3:51 pm

Wladimir Palant wrote:in Adblock Plus 1.1 [...] the lowest supported versions will be:

* SeaMonkey 2.0b1


Installation of adblockplus-1.1.alpha+.2009050712-en-US.xpi in SeaMonkey-2.0b1 fails during compatibility check.

Build identifier is: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b5pre) Gecko/20090514 SeaMonkey/2.0b1pre

Should ADP 1.1 alpha work with that SeaMonkey version or is a "pre" version not good enough?
Gunther Nikl
 

Re: [Done] Removing support for Firefox 2 & Co

Postby Wladimir Palant » Sat May 16, 2009 11:32 pm

Gunther Nikl wrote:Build identifier is: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b5pre) Gecko/20090514 SeaMonkey/2.0b1pre

2.0b1pre isn't quite the same as 2.0b1. However, current nightlies should work fine - so I changed install.rdf again, next development build will be marked compatible with SeaMonkey 2.0b1pre.
Wladimir Palant
ABP Developer
 
Posts: 8332
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Postby Wladimir Palant » Mon May 25, 2009 7:48 pm

GodzFire, I moved your post into a separate topic: https://adblockplus.org/forum/viewtopic. ... 6736#26736
Wladimir Palant
ABP Developer
 
Posts: 8332
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Postby Wladimir Palant » Tue Jun 02, 2009 9:41 am

For reference, current application usage statistics for Adblock Plus:

Image

And same thing without Firefox 3.0:

Image

Firefox 2.0 share is currently at 4%, Thunderbird 2.0 is at 0.5%. SeaMonkey 1.1 isn't in the statistics because it doesn't have automatic extension update, SeaMonkey 2.0 is in the stats but indistinguishable from zero.
Wladimir Palant
ABP Developer
 
Posts: 8332
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany

Re: [Done] Removing support for Firefox 2 & Co

Postby K-M user » Tue Jul 07, 2009 9:40 pm

Wladimir Palant wrote:eMusic Remote and K-Meleon will no longer be supported - these are still based on Gecko 1.8.1 and no new version seems to be coming up.


Next major K-Meleon release will be based on Gecko 1.9. There is already K-Meleon Beta 1.6 based on Gecko 1.9. Would you kindly continue supporting this great browser? I really appreciate you make an effort supporting K-Meleon 1.5.x.

Regards
K-M user
 

Re: [Done] Removing support for Firefox 2 & Co

Postby Wladimir Palant » Wed Jul 08, 2009 2:00 pm

K-M user wrote:There is already K-Meleon Beta 1.6 based on Gecko 1.9.

You mean this one? That's not a beta, it isn't even an alpha. That's only slightly better than "you can go build yourself something from the source code." I'll continue to support K-Meleon when they at least release a version that works out of the box.
Wladimir Palant
ABP Developer
 
Posts: 8332
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany


Return to Future development

Who is online

Users browsing this forum: No registered users and 0 guests