It seems that an issue caused all filters to be removed...

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey

It seems that an issue caused all filters to be removed...

Postby puzzled » Wed Apr 17, 2019 6:37 pm

Hi guys! This must be an old issue considering I don't see anyone asking about it. Firefox crashed so I got the message:
It seems that an issue caused all filters to be removed and we were unable to restore a backup. Therefore we had to reset your filters and Acceptable Ads settings.
Please check your filter lists and Acceptable Ads settings in the Adblock Plus options.

The first time that happened the filter appeared by itself eventually, or maybe after I clicked something by mistake? Thing is it was working OK. Few days after it crashed again and now it's been without any filter lists, neither the blocked items I had added.

I wanna add them back manually but I have no idea what filters I was using before, neither if I should simply Google to read what people are saying about it.
I prefer playing it safe and ask directly in the ABP forum. Is there a way for me to know what filters I was I using before (actually my brother since this laptop used to be his) so I can install them back, getting the correct URL or even if there's no way to do that, is there a way to know safe URL's of filters lists to add? Or knowing which filters most people are using so I don't end up becoming a test dummy for someone.

The crashing and deleting is annoying yes, but I wish I knew how to work around it. Needless to say I know very lil to nothing when it comes to computers.
If by any chance this issue was solved and I'm being repetitive, please link me to the thread so I don't bother the forum with an already solved issue, thank you and sorry for the broken English!
puzzled
 
Posts: 5
Joined: Wed Apr 17, 2019 6:20 pm

Re: It seems that an issue caused all filters to be removed...

Postby mapx » Wed Apr 17, 2019 8:15 pm

1. You ca try using a new firefox profile (could be your current one is corrupt), install again ABP and see what happens.
or
2. Disable ABP, install another (very strong) adblocker: ublock origin (uBo) and see if works for you. uBo has the possibility to create a backup, so - even if something crashes - you can simply restore the settings (including the custom filters) from the backup.
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: It seems that an issue caused all filters to be removed...

Postby puzzled » Fri Apr 19, 2019 3:55 pm

mapx wrote:1. You ca try using a new firefox profile (could be your current one is corrupt), install again ABP and see what happens.
or
2. Disable ABP, install another (very strong) adblocker: ublock origin (uBo) and see if works for you. uBo has the possibility to create a backup, so - even if something crashes - you can simply restore the settings (including the custom filters) from the backup.

So sorry, I didn't click on 'notify me when a reply is posted'... I just read this! I'll give it a shot, thank you!
puzzled
 
Posts: 5
Joined: Wed Apr 17, 2019 6:20 pm

Re: It seems that an issue caused all filters to be removed...

Postby LiamA » Thu Apr 25, 2019 5:11 pm

I've been noticing a similar problem too. When I start Firefox either the adblock filters won't load or are slow in loading. I'll have to close Firefox and reopen it to get adblock to work.
LiamA
 
Posts: 4
Joined: Thu Apr 25, 2019 4:56 pm

Re: It seems that an issue caused all filters to be removed...

Postby kdw » Fri Apr 26, 2019 10:55 pm

I get the same annoying message with every login but Adblock Plus does work without rebooting. There was a similar problem reported with the Microsoft Edge browser awhile back. Is Adblock working on a fix other than telling us to do a lot of work?
kdw
 
Posts: 1
Joined: Fri Apr 26, 2019 10:50 pm

Re: It seems that an issue caused all filters to be removed...

Postby jimmybond » Sat Apr 27, 2019 8:16 pm

Hi - same issue here. Started a couple weeks ago. Running Firefox 66.0.3, WIndows 10, every time I open the browser I get that annoying error message (with the tab name saying "Installation successful!")
I do not even have any custom filter lists, just use ABP filters, EasyList, and Allow nonintrusive advertising

I have not tried creating a new Firefox profile but if this continues it'll be the ABP plugin that gets deleted, not my profile, as there are other ad blocking options out there...hope they can come up with a fix.

full error message: "It seems that an issue caused all filters to be removed and we were unable to restore a backup. Therefore we had to reset your filters and Acceptable Ads settings. Please check your filter lists and Acceptable Ads settings in the Adblock Plus options."
jimmybond
 
Posts: 1
Joined: Sat Apr 27, 2019 8:13 pm

Re: It seems that an issue caused all filters to be removed...

Postby Tokala » Sat Apr 27, 2019 10:06 pm

I have similar issue, every time i close my browser, all my settings reset and all filter lists disappear. However when start the browser i do not get an error message or installation succesful notifycation. This happens on Firefox 66.0.3 on Win10. It started happening just a few days ago and i dont know the reason. It's frustrating to load all the lists on every restart, also it feels that adblock doesnt block all the ads that it did before.
Tokala
 
Posts: 1
Joined: Sat Apr 27, 2019 9:47 pm

Re: It seems that an issue caused all filters to be removed...

Postby mapx » Sat Apr 27, 2019 10:08 pm

User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: It seems that an issue caused all filters to be removed...

Postby DanNeely » Tue Jun 04, 2019 5:15 pm

I have a recent profile backup. What files do I need to restore from it to fix this?
DanNeely
 
Posts: 3
Joined: Fri Sep 21, 2012 9:22 pm

Re: It seems that an issue caused all filters to be removed...

Postby luftwaffles » Tue Jun 18, 2019 10:56 pm

same problem just started happening to me.
luftwaffles
 
Posts: 3
Joined: Tue Jun 18, 2019 10:47 pm

Re: It seems that an issue caused all filters to be removed...

Postby mapx » Tue Jun 18, 2019 11:31 pm

see above, try ublock origoin, test if you get same issues
User avatar
mapx
 
Posts: 21947
Joined: Thu Jan 06, 2011 3:01 pm

Re: It seems that an issue caused all filters to be removed...

Postby Shaun » Fri Jul 12, 2019 11:20 am

"It seems that an issue caused all filters to be removed and we were unable to restore a backup. Therefore we had to reset your filters and Acceptable Ads settings. Please check your filter lists and Acceptable Ads settings in the Adblock Plus options."

I get this every time I start Firefox 68 (Mac).
I reset the filter.
close Firefox.
open Firefox - and up cpmes the same message.
Does no-one at Adblocker have a fix for this?
Shaun
 
Posts: 2
Joined: Fri Jul 12, 2019 11:12 am

Re: It seems that an issue caused all filters to be removed...

Postby Shaun » Fri Jul 12, 2019 3:29 pm

Solution, for me anyway - delete adblocker plus from Firefox add-ons.
Then reinstall from adblocker ste.
All working now.
Shaun
 
Posts: 2
Joined: Fri Jul 12, 2019 11:12 am

Re: It seems that an issue caused all filters to be removed...

Postby mike603 » Thu Oct 24, 2019 4:45 pm

I am also experiencing this with Firefox 70.0 and Adblockplus 3.7.

I am going to try re-installing Adblockplus.
mike603
 
Posts: 1
Joined: Thu Oct 24, 2019 4:41 pm

Re: It seems that an issue caused all filters to be removed...

Postby goodmanndocs » Sun Nov 10, 2019 1:02 am

thanks much for help and bless your heart. i was having issues accessing my site führerschein-online-kaufen.com and köpkörkort.com but now, the issue has been resolved :P :P :P
goodmanndocs
 
Posts: 1
Joined: Sun Nov 10, 2019 12:59 am
Location: köpkörkort.com

Next

Return to Adblock Plus for Firefox support

Who is online

Users browsing this forum: No registered users and 20 guests