Adblock Plus and (a little) more

Element Hiding Helper 1.0 released · 2007-01-23 02:31 by Wladimir Palant

This is the first release of the Element Hiding Helper extension for Adblock Plus.

Installation

Update: Issue with faulty single-language builds is fixed.

Features

  • Simple but powerful selection of the element to be hidden (thanks Aardvark)
  • Automatic generation of an element hiding rule based on specified criteria
  • Advanced mode for complicated rules, allows selecting attributes of parent and sibling nodes, attribute parts and custom CSS
  • Rules are applied immediately, with “Preview” switched on even during composing

Known issues

  • Preview feature doesn’t work in Mozilla Mail/Thunderbird
  • View source tooltip’s position and size is influenced by other tooltips
  • Wrong frame position and size for inline elements that are broken into multiple lines

Tags:

Comment [19]

  1. IceDogg · 2007-01-23 02:57 · #

    Major bug. This kills all other extensions other the adblock plus for me. Including itself (Element Hiding Helper).

    Ones I had that it killed included stylish,bbcode,Noscript (recently reinstalled) and other not so popular ones..but if you need them let me know. AFAICT it killed them all. No status bar buttons for any other then adblock, no right click menu items for them eg bbcode. So on.

    En only version
    OS-Vista x86
    Firefox- Minefield
    latest on all extensions

    More Info Disabled everything would work, enable they were all gone again. Uninstall all would work.

    Reply from Wladimir Palant:

    No issues with Minefield here. Might be a conflict with one of your extensions however – does Error Console say anything?

  2. Mishail · 2007-01-23 04:32 · #

    Hmmm… there is something wrong. After installation of Element Hiding Helper 1.0 I get this bug:

    http://mishail.mishail.googlepages.com/helperbug.png (33,47 KB)

    And following messages in the console:

    Warning: Failed to load overlay from chrome://elemhidehelper/content/overlay.xul.
    Source File: chrome://browser/content/browser.xul
    Line: 0

    Error: no element found
    Source File: chrome://elemhidehelper/content/overlay.xul
    Line: 1, Column: 1
    Source Code:

    Though previous dev. versions of Helper worked fine for me
    OS: WinXP
    Firefox : 2.0.0.1

  3. Mishail · 2007-01-23 04:41 · #

    UPD: Build 0.9+.2007011100 works without problem.

  4. Mishail · 2007-01-23 04:53 · #

    UPD2: This happens only with en-US single-language build. This one http://adblockplus.org/downloads/elemhidehelper-1.0.xpi works fine for me.

    Sorry for spam in comments.

    Reply from Wladimir Palant:

    Thanks for finding this out. I am investigating this issue – the builds seem fine but Firefox doesn’t accept them for some reason.

  5. rick752 · 2007-01-23 05:00 · #

    Ouch.
    Released version made my Firefox unusable (things disabled, no page loads). Had to uninstall and go back to the dev build.

    Something didn’t go right…

  6. IceDogg · 2007-01-23 06:25 · #

    Confirming what Mishail said.. it’s only the en-US single-language build, but I did stat that was the one I installed in my first post.

  7. dizzy2 · 2007-01-23 07:52 · #

    Подтверждаю проблему Mishail. С ru-RU та же ошибка.

  8. IntelliMoo · 2007-01-23 09:06 · #

    1.0 definitely busted. Command is not added to my adblockplus toolbar icon and doesn’t activate with the hotkey either.

  9. Mishail · 2007-01-23 09:23 · #

    Guys, don’t use single-language builds.

  10. IntelliMoo · 2007-01-23 21:30 · #

    Works now, installed from mozilla addons site instead.

    Reply from Wladimir Palant:

    I fixed the single-language builds hours ago…

  11. Greg · 2007-01-24 04:57 · #

    Any plans to integrate this into Adblock Plus fully? Or are you going to leave it as a separate extension?

    Reply from Wladimir Palant:

    It is going to stay a separate extension – see http://adblockplus.org/blog/adblock-plus-on-the-crossroads.

  12. Andy · 2007-01-24 19:18 · #

    Still broken. I installed it from mozilla addons as well as from this site. I tried the single language build as well as the full install and it just breaks most of my extensions after I restart firefox. The Ad Block Plus menu actually still shows up, but the option for selecting elements to block is not there.

    I am running a fresh install of firefox 2.0.0.1 with a clean ~/.mozilla directory.

    I have only installed the following extensions:

    Adblock Filterset.G Updater 0.3.0.5
    Adblock Plus 0.7.2.4
    Google Notebook 1.0.0.11
    Google Toolbar for Firefox 2.1.20060807L
    Mozex 1.9.5
    MR Tech Local Install 5.3.2.3
    Tab Mix Plus 0.3.5.2

    Reply from Wladimir Palant:

    The error message from the Error Console would be helpful.

  13. Greg · 2007-01-25 10:41 · #

    Works good for me. I very useful addition to Adblock Plus. Thank you very much.

  14. tatar0900 · 2007-02-03 14:05 · #

    how to undo filters created???

    Reply from Wladimir Palant:

    As usually – you open Adblock Plus Preferences and remove the filter you don’t want.

  15. cb · 2007-02-04 06:40 · #

    This has saved me from twiddling around in Stylish so much for those little annoyances. (It also showed me what Aardvark can do — its own site left me wondering.) Thanks!

  16. Eric · 2007-04-07 09:45 · #

    I blocked all the elements on kitco.com and lost all the navigation along with everything else. How to undo everything when there are so many elements blocked in the dropdown box at the top of the preferences page. Do I have to click on every one and delete it individually?, since I don’t see a way to unblock the whole site. A @@ filter doesn’t seem to unblock it either.

    Reply from Wladimir Palant:

    You can select multiple filters and delete them all at once if you like (pressing the Delete key will work). But yes, you will have to do this, exception rules have no effect on element hiding (yet).

  17. st · 2007-07-27 04:01 · #

    One thing I’m not clear about: If you’re blocking a banner ad, is the banner never downloaded? Or is the banner downloaded but not rendered?

    The reason I’m asking is that I want the sites I visit to get a little money from their banner ads. If the sites won’t get any money, then I’d rather not block their banner ads.

  18. Captain Canuck · 2009-11-14 02:42 · #

    Same problem still partially exists
    (since Mishail reported it):

    Error: no element found
    Source file: chrome://browser/content/browser.xul
    Line: 1

    Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
    Adblock Plus: Element Hiding Helper 1.0.6

    Reply from Wladimir Palant:

    I think that problem is caused by .Net Framework Assistant (even if it doesn’t show up in your list of add-ons). See http://support.microsoft.com/kb/963707 (method 2) for removing that annoyance.

  19. Captain Canuck · 2009-11-15 17:32 · #

    Read my User-Agent

    Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
    Adblock Plus: Element Hiding Helper 1.0.6

    Reply from Wladimir Palant:

    Right, overlooked that one. The problem that Mishail reported is definitely gone however, whatever you see must be something else. Are you certain that message is caused by Element Hiding Helper? Does it also happen if all other extensions are disabled?

Commenting is closed for this article.