Adblock Plus 1.0 for Internet Explorer released · 2013-08-13 17:15 by Wladimir Palant

Install Adblock Plus 1.0 for Internet Explorer

We proudly present you the first Adblock Plus release for Internet Explorer! While there is still much room for improvement, we feel that the current version is ready to be used. It is compatible to any Internet Explorer version down to Internet Explorer 6 on Windows XP with the following limitations:

Other than that we’ve resolved most of the issues our original development build was experiencing. The one issue remaining is the placement of the icon: Adblock Plus icon still shows up in the status bar and normally you will need to enable it manually to show it. Also, we are aware of some remaining inconsistencies in the way blocking and element hiding rules work in Internet Explorer compared to Firefox or Chrome, we will continue working on eliminating these.

Tags:

Comment [28]

  1. S. Jaouani · 2013-08-13 18:13 · #

    Awesome! Very useful for people still stuck with IE.

  2. casaout · 2013-08-13 20:31 · #

    Fantastic, thank you so much! Now, I can finally go back to IE (fast & secure).

  3. DaCritic · 2013-08-14 03:24 · #

    Unfortuantely it’s not working on IE 8 Windows XP. The Addon shows up in Manage Add-Ons as Enabled but no icon on the status bar and still seeing ads.

  4. Malabar · 2013-08-14 07:59 · #

    I have the same experience as DaCritic.

    Is this based on code from Simple Adblock?

    I can install and run Simple Adblock 1.1.5 without issue.

  5. vlass · 2013-08-14 21:53 · #

    Thanks for this! Great work

  6. dude · 2013-08-14 22:16 · #

    what about safari

  7. Kenny · 2013-08-15 01:24 · #

    Any chance you’re going to develop for Safari? Thanks!

    Reply from Wladimir Palant:

    A Safari port is already in progress.

  8. Arerifx · 2013-08-17 06:51 · #

    How to manually enable the ABP icon to show up?

    Reply from Wladimir Palant:

    The icon is always there but you need to show the status bar (exact steps to follow depend on Internet Explorer version).

  9. Antsa · 2013-08-18 11:16 · #

    Any chance you’re going to develop for Windows Phone, iPad and iPhone? Thanks!

  10. Jon · 2013-08-19 08:23 · #

    Holy shit, thank you so much

  11. an12179 · 2013-08-22 03:03 · #

    Why can’t I play videos from espn.com or cnet.com? I have Windows 8, IE 10. If I disable adblock plus, the videos play fine. This is not listed in your limitations. Are you saying that play fine?

  12. Lawrence · 2013-08-23 11:00 · #

    This is not working in IE on an XP machine

  13. JustSayinEP · 2013-08-23 16:03 · #

    No icon on the status bar. Windows 7, IE8. Ads still show.

  14. Alex · 2013-08-25 11:36 · #

    Thank you! Windows 7 (x86), IE 10 – it works! Finally I have this great add-on for IE! But, if I click on Settings, nothing happens. But it’s not so critical.

    I like background on your web-page, by the way. You know what is good ergonomics. But a lot of web-designers, who offer white background without any texture, don’t.

  15. Pat · 2013-08-27 12:45 · #

    Hi, I tried to download the version for Internet Explorer and received a message something like “403 this is forbidden”. I managed to download it to Google Chrome okay. I guess I will surf the internet with Chrome for the meantime but wondered if anybody else had come across this issue and what might be causing it.

    Reply from Wladimir Palant:

    Everything seems to be fine on our end. It might be that some security software prevents downloading executables on your end.

  16. RJ · 2013-08-30 22:08 · #

    Running Windows XP SP3 IE8
    Adblock Plus for IE is not working for me.
    Any suggestions?

  17. Tim · 2013-09-01 13:02 · #

    Please put the ABP icon in address bar like Adblock IE.
    http://www.adblockie.com/images/screenshot1.jpg

  18. K · 2013-09-04 18:21 · #

    Same problem with ESPN.com, but it’s only in Internet Explorer. Works fine in Chrome and Firefox.

  19. Laumi · 2013-09-05 18:32 · #

    please Support IE 11

  20. Jaq · 2013-09-05 19:47 · #

    Great, thanks you!! However, please make it compatible to IE 11 soon so that I can get back to IE after a few years using FF ;-)

  21. senthil · 2013-09-06 07:11 · #

    Great work guys, excellent work, worked like a charm in IE11 Desktop mode : )

  22. EM · 2013-09-15 01:51 · #

    Running Vista 64, IE 9. I have installed (and uninstalled) Adblock three times. There is no Adblock icon in my status bar and ads are not blocked. Adblock is listed as enabled in my add-ons. Quite a few people report this problem on the adblock forum but no working solution. I have adblock for Firefox and Opera and they work great. I hope future releases of Adblock for IE will work for me.

  23. David · 2013-09-15 17:24 · #

    I’ve installed AdBlock for IE using IE 8 and XP SP 3, It works perfectly for me. IE 8 has gained significant improvements in speed. It doesn’t block every single adm but it still works. Remember this is just version 1.0 and later improvements will be made. The icon appears at the bottom right of the window and the menu is available via right click. For me, it works just fine.

  24. EM · 2013-09-15 21:16 · #

    I know this isn’t the tech forum but I wanted to share the solution that worked for me. “Enable third-party browser extensions” was disabled in Internet Options. After checking this, Adblock icon is now showing up in my status bar and Adblock is functioning properly. Thx.

  25. Anon · 2013-09-16 04:21 · #

    I’d prefer to actually hide the icon. It stands out as a red stop sign, and this looks odd on the blue-icon filled Internet Explorer.

  26. Bookman · 2013-09-16 20:09 · #

    Windows 8 – no icon. Also, adding attachments to e-mails in bt yahoo mail is compromised – uninstalling cured this but I’d still like to try again?

  27. MacBook Air · 2013-09-18 16:08 · #

    It doesn’t work for IE 11 on Windows 8.1

  28. Rawr · 2013-09-21 10:12 · #

    Win 7 ×64 + IE11 Preview

    v1.0 installs fine. ABP ran fine.

    AdblockPlusEngine.exe though takes up 600Mb+ if left with ie open and just surfing casually.

    https://adblockplus.org/forum/viewtopic.php?t=16990 (seems I’m not the only one with this issue as well). Hopefully a fix is issued soon. Until then I’ll uninstall for now or just try the Dev build v1.0.533

Commenting is closed for this article.